View Issue Details

IDProjectCategoryView StatusLast Update
0000022HTML & PERLBug Report - Interfacepublic2009-07-25 00:03
Reporterninjamask Assigned ToDerIdiot  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000022: Broken link in the mylist info box on any anime page with default lang not Romaji
DescriptionThe link to the right page of your own mylist in the mylist info box on any anime page dun work if you don't use Romaji as default title language.
Additional Informationhttp://www.anidb.net/forum/viewtopic.php?t=2534

Skywalka:
I just deleted a file from "Ghost in the Shell - Stand Alone Complex". AniDB then took me to my mylist (as usual) to show me which files I have.

It took me to the letter "K" - which would be right, if I had GitS - SAC listed under the original title, "Koukaku Kidoutai STAND ALONE COMPLEX", which I don't. I then clicked the link for the letter "G" and there I was given what I looked for, with the "GitS SAC"-tree already expanded.
Tagsmylist

Relationships

has duplicate 0000647 closed &char=x part of the link to mylist from animepage should respect language preferences or be removed 
has duplicate 0000854 closed some mylist records do not show up 

Activities

exp

2004-12-02 20:17

administrator   ~0000020

known problem.
however, at least for language=kanji this can't be fixed easily.
don't expect to see a fix soon.

BYe!
EXP

bbaab

2005-03-04 08:56

reporter   ~0000290

Last edited: 2005-03-04 08:59

I think you need a "japanese sorting" column for this to work. Every japanese anime listing I've seen just uses the katakana/hiragana "alphabet" (A-I-U-E-O-KA-KI-KU-KE-KO and so on ...) with non-japanese names first transcribed into this and sorted alongside all the other names (thus, "DearS" is sorted among the other "DE" anime because its transcription starts with a "DE" and a small "I", "KURAU" is sorted alongside the other anime starting with "KU" and so on).

There are less than 80 different possible kana (a few over 80 with the small variants of A, I, U, E, O, YA, YU, YO and TSU). If you need them for sorting and nothing else (and can put up with decoding/encoding them for display and entry), you can just use a byte for each and use a simple non-charset-aware string sorting to get correct japanese sorting.

EDIT: fscking tracker can't fscking display the fscking japanese kana. Sorry for my French.

Rar

2005-03-04 22:43

reporter   ~0000291

As katakana, hiragana, roman and kanji scripts are treated the same, and letters with dakuten or handakuten are grouped with those without, collation in japanese generally has 45 indices rather than 80 or more.
This isn't something exp could code himself though, he'd need some kind of bolt on code to handle japanese searching/sorting properly.

Rar

egg

2005-03-04 23:06

reporter   ~0000292

This could be fixed for english though... 8)

bbaab

2005-03-05 09:34

reporter   ~0000293

Give me the target (programming) language and I'll write the collation routines. Hell, I'll write a perl-accessible C library for that if speed is an issue.

exp

2005-03-06 09:35

administrator   ~0000294

I use SQL ORDER BY statements to sort the anime titles.
Non-Ascii titles are currently stored in their html-escaped form, which would make correct sorting near to impossible I'd guess :|

In the long run this could probably be fixed by completly moving to unicode UTF8 encoding in the db, in the perl cgis, the cron jobs, the irc bots and the apis.
I've looked into that about a year ago once and had quite some compatibility issues. But I'll probably try it again once we've had the time to update the base software (perl, libs, ...) on the server anidb is hosted on.

Until then I don't think there is any viable way to fix it.

bbaab

2005-03-07 08:28

reporter   ~0000296

The point is that NO encoding won't help you in sorting the japanese titles, simply because the Japanese way is to sort by the pronunciation of the titles (as transcribed into kana, where necessary). You absolutely need a "sorting" column for that in addition to the "displayed title" column we already have. The former doesn't need to be in any particular encoding.

Harkonnen

2007-05-08 06:23

reporter   ~0001251

two years old and still unresolved? maybe instead of trying to make sorting work correctly for any default language just modify expand=xxxx so in wont show all the titles before this one on a single page and drop char=x part from the link?

exp

2007-12-29 08:29

administrator   ~0001574

hehe, we should probably look at this again, yeah }:o)

DerIdiot

2009-07-25 00:03

administrator   ~0002882

that seems fixed to me

Issue History

Date Modified Username Field Change
2004-12-02 18:54 ninjamask New Issue
2004-12-02 20:16 exp Status new => assigned
2004-12-02 20:16 exp Assigned To => exp
2004-12-02 20:17 exp Note Added: 0000020
2004-12-02 20:17 exp Status assigned => confirmed
2005-03-04 08:56 bbaab Note Added: 0000290
2005-03-04 08:59 bbaab Note Edited: 0000290
2005-03-04 22:43 Rar Note Added: 0000291
2005-03-04 23:06 egg Note Added: 0000292
2005-03-05 09:34 bbaab Note Added: 0000293
2005-03-06 09:35 exp Note Added: 0000294
2005-03-07 08:28 bbaab Note Added: 0000296
2006-07-17 12:50 DerIdiot Additional Information Updated
2007-05-08 05:44 epoximator Relationship added has duplicate 0000647
2007-05-08 05:45 epoximator Summary Broken link in the mylist info box on any anime page with fefault lang not Romaji => Broken link in the mylist info box on any anime page with default lang not Romaji
2007-05-08 06:23 Harkonnen Note Added: 0001251
2007-12-29 08:26 exp Relationship added has duplicate 0000854
2007-12-29 08:28 exp Assigned To exp =>
2007-12-29 08:29 exp Note Added: 0001574
2007-12-29 08:29 exp Status confirmed => acknowledged
2007-12-29 08:30 exp Priority normal => high
2008-02-10 22:02 ninjamask Tag Attached: mylist
2009-07-25 00:03 DerIdiot Note Added: 0002882
2009-07-25 00:03 DerIdiot Status acknowledged => resolved
2009-07-25 00:03 DerIdiot Resolution open => fixed
2009-07-25 00:03 DerIdiot Assigned To => DerIdiot