View Issue Details

IDProjectCategoryView StatusLast Update
0002978AJAX/JSBug Report - Interfacepublic2017-09-01 14:21
ReporterSoulweaver Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2017-09 
Summary0002978: Anime page: Mylist actions in episode list appear for episodes with any odd number of files on mylist
DescriptionOne of the available columns for the episode list is the actions column that includes a few actions to modify the mylist entry for the file for that episode. Logically, since those links only affect one file's entry, they should only appear when you have a single file on mylist for that episode. It appears that has been the intention too as per issues 0002759 and 0002758. However, the actions actually appear for any episode where an odd number of files is present, not just for those with exactly one.

In the attachment a case for 3 files for an episode can be seen, but I checked some other episodes with even more files, and this consistently seemed to the case for any odd numbers of files.
TagsNo tags attached.

Activities

Soulweaver

2017-08-04 07:20

reporter  

fileactions.png (474,945 bytes)

Issue History

Date Modified Username Field Change
2017-08-04 07:20 Soulweaver New Issue
2017-08-04 07:20 Soulweaver File Added: fileactions.png
2017-08-04 09:37 DerIdiot Project AniDB Website => HTML & PERL
2017-08-04 09:38 DerIdiot Project HTML & PERL => AJAX/JS
2017-09-01 14:21 DerIdiot Assigned To => DerIdiot
2017-09-01 14:21 DerIdiot Status new => resolved
2017-09-01 14:21 DerIdiot Resolution open => fixed
2017-09-01 14:21 DerIdiot Fixed in Version => 2017-09