View Issue Details

IDProjectCategoryView StatusLast Update
0002996HTML & PERLBug Report - Interfacepublic2017-08-29 23:55
ReporterSoulweaver Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2017-09 
Summary0002996: Creq: Changed date field values in character creqs don't appear properly
DescriptionWhenever I write anything in the birth or death date fields while trying to edit characters, the resulting creq doesn't seem to have anything in those fields as new values regardless of what I write in (but the fields are still marked as having changes even if they were originally blank). It appears to be a display issue on the new values side, since they also appear blank in this creq (http://devint.anidb.net/c8555423), which succesfully changed the date at the time, while http://devint.anidb.net/c8681515 shows the old value side properly but not the new value side.

The creq on live on which I noticed this: https://anidb.net/c8899027 (tried to enter DoB ??.??.1860, DoD ??.??.1905)
The creqs I tested with on devint: http://devint.anidb.net/perl-bin/animedb.pl?show=creq&do.showhistov=1&table=chartb&id=46424 (tried both regular dates and dates with ?s) + http://devint.anidb.net/c8681515 (tried changing the date while keeping the year unknown).

I didn't test other entity types with date fields.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-08-28 21:58 Soulweaver New Issue
2017-08-29 12:36 DerIdiot Assigned To => DerIdiot
2017-08-29 12:36 DerIdiot Status new => resolved
2017-08-29 12:36 DerIdiot Resolution open => fixed
2017-08-29 12:36 DerIdiot Fixed in Version => 2017-09