View Issue Details

IDProjectCategoryView StatusLast Update
0003156HTML & PERLBug Reportpublic2020-01-17 19:36
ReporterHinoe Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003156: Tag names: modediting the main tag name via creq edit interface does not update the entry's date or register the creq comment
Descriptionhttps://anidb.net/perl-bin/animedb.pl?show=addtagname&tagid=6509

Main name date: 2015-09-03. Click history. Latest edit: 2018-03-16. Creq for the edit: https://anidb.net/c9417284

I issued this edit via creq edit interface for https://anidb.net/c9416800 and wrote a comment when I did so, but the comment was not added and had to be included manually later.

I made a few tests on devint and got the following results. This applies only to change to the tag name; editing the creq description via the same interface makes all happen as expected. It only happens via creq edit interface; editing the name it via the normal tag edit page (or via the add tag names page) works as expected. It happens regardless of whether the creq being edited is a tagreltb one (as in this case) or a tagdatatb one.

I haven't tested what will happen if the user edits his own creq to issue a creq or owneredit (as applicable) to the name.

Please note that the ability for creq issuer, maintainers, and mods to edit a separate part of the tag while the creq is pending (e.g. edit tagdatatb while pending tagreltb) is actually useful when handling creqs that require further edits. I'm not sure this is an intended possibility, but if not, it should be kept, as it's good.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-03-16 20:08 Hinoe New Issue
2020-01-17 19:36 DerIdiot Assigned To => DerIdiot
2020-01-17 19:36 DerIdiot Status new => resolved
2020-01-17 19:36 DerIdiot Resolution open => fixed