View Issue Details

IDProjectCategoryView StatusLast Update
0003252HTML & PERLFeature Request - Interfacepublic2020-01-17 15:50
ReporterCDB-Man Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003252: adb_log: for relation type log entries, have the hotlink go directly to the relation edit page
DescriptionFor example, for this log entry:
https://anidb.net/perl-bin/animedb.pl?show=log&s=0&start.at=-&filter.uid=726995&filter.id1=170454&filter.id2=92211&filter.id3=&filter.type=311&do.filter=Apply

The hotlink should go to https://anidb.net/perl-bin/animedb.pl?show=addcharcharrel&charid=92211&addccrel.sid=170454
Additional Information20:32:11 CDB-Work> question: https://anidb.net/perl-bin/animedb.pl?show=userinfo&uid=726995
20:32:19 CDB-Work> 2018-06-14 17:40 CHARCHARREL NEW 170454
20:32:32 CDB-Work> 170454 links to this: https://anidb.net/perl-bin/animedb.pl?show=character&charid=170454
20:32:47 CDB-Work> instead of the char rel
20:33:36 CDB-Work> i can file a tracker entry for this, but my immediate question is, what's thje short url to lookup that char rel?
20:34:30 CDB-Work> also why is there no 2nd char id for that entry?
20:34:37 CDB-Work> at least on the uiserinfo page
20:37:46 ~deriDIOt> there fixed
20:39:50 CDB-Work> link fixed. but the related entry 2 column still doesn't lookup the other side
20:40:02 CDB-Work> not for all of them, anways
20:40:02 ~deriDIOt> ?
20:40:10 CDB-Work> i will make a screenshot
20:40:19 ~deriDIOt> no just tell me what you want
20:41:19 CDB-Work> the column "related entry 2", for charcharrel, does not show the charid of the other char
20:41:31 ~deriDIOt> so?
20:41:52 CDB-Work> can we show the charid of the other char of the charcharrel?
20:42:05 ~deriDIOt> it's not logged that way
20:42:07 ~deriDIOt> hence, no
20:42:20 ~deriDIOt> i can not createe data out of thin air
20:42:35 CDB-Work> is that because its an ADD?
20:42:43 ~deriDIOt> no
20:42:52 ~deriDIOt> it's because that's how the person that coded it set it
20:42:57 CDB-Work> oh well
20:43:06 CDB-Work> if it had been an edit of the rel instead, would it log both char id then?
20:43:16 ~deriDIOt> no
20:43:44 ~deriDIOt> adb_log::log('CHARCHARREL_EDIT', $dbe->{'id'}, $adb_conf::d->{'Zuid'}, $odbe->{'charid'});
20:44:12 ~deriDIOt> adb_log::log('CHARCHARREL_NEW', $dbe->{'id'}, $adb_conf::d->{'Zuid'}, $dbe->{'charid'});
20:44:34 CDB-Work> hmm, in that case. can we change the hotlink on the charid, to this instead so that it links you directly to the edit page of that rel: https://anidb.net/perl-bin/animedb.pl?show=addcharcharrel&charid=92211&addccrel.sid=170454
20:45:50 CDB-Work> i did a quick reviewof this guy's char rels, and they _seem_ okay, but i know nothing about the shows hes touched
20:46:10 ~deriDIOt> none of the other links do
20:47:02 CDB-Work> maybe then this is a feature request to have the other links do the same, i cna file a ticket
20:48:24 ~deriDIOt> then go edit adb_log. i can't be arsed
20:49:19 CDB-Work> hmm, so editing how the links show up globally, are all handled by adb_log (not just the generation of the log itself)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-09-09 00:56 CDB-Man New Issue
2020-01-17 15:50 DerIdiot Assigned To => DerIdiot
2020-01-17 15:50 DerIdiot Status new => resolved
2020-01-17 15:50 DerIdiot Resolution open => fixed