View Issue Details

IDProjectCategoryView StatusLast Update
0000757HTML & PERLBug Report - Interfacepublic2008-02-25 08:19
Reportertwpol Assigned Toepoximator  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000757: Release Info popup looks bad (loses some site styles)
DescriptionThe icons and text in the Release Info popup (Wishlist, 'to get' items) seem very jumbled up and confused - generally failing to convey everything they should.

This is partly because some site styles don't get applied when the content is copied into the tooltip element, as it is not inside #layout-content. At least one rule is lost because of this:

/* Rule 63 of http://static.anidb.net/css/anidbstyle/anidbstyle.css */
#layout-content *.icons *.i_icon {

This rule happens to be the one which sets "float: left;" for the icons, which is a major contributor to the odd result in the popup.

I'm not sure there is any necessity for the #layout-content part of the rule, and it could probably be simplified to just "*.icons *.i_icon".

Even having fixed this locally, the display wasn't perfect, as the floats were interfearing with each other now. The fix was to apply "clear: left;" to "*.icons" - but as I did this directly in the page, I don't know if this needs more care for use globally on the site (might mess up other places that use icons).
TagsCSS

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2007-09-07 22:04 twpol New Issue
2007-09-11 08:35 epoximator Status new => assigned
2007-09-11 08:35 epoximator Assigned To => epoximator
2007-12-06 07:49 epoximator Assigned To epoximator =>
2007-12-06 07:49 epoximator Status assigned => new
2008-02-13 00:56 ninjamask Tag Attached: CSS
2008-02-25 08:19 epoximator Status new => resolved
2008-02-25 08:19 epoximator Resolution open => fixed
2008-02-25 08:19 epoximator Assigned To => epoximator