View Issue Details

IDProjectCategoryView StatusLast Update
0001054HTML & PERLBug Report - Interfacepublic2008-05-22 17:39
Reporterncmaothvez Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001054: Ampresands ('&') in group names are displayed as '&' in Episode List on anime page
DescriptionAs the sumary says.

Example title:
http://anidb.net/perl-bin/animedb.pl?show=anime&aid=4156&gid=3376#eplist

Webbrowser used:
FireFox 2.0.0.12

Tried with anidbstyle and SubSilver CSS - no difference.
TagsNo tags attached.

Relationships

has duplicate 0001150 resolvedfahrenheit Symbol in groupnames at episode details "&" 

Activities

2008-04-02 19:28

 

AmpBug.png (22,909 bytes)
AmpBug.png (22,909 bytes)

ncmaothvez

2008-04-02 19:31

reporter   ~0001890

Last edited: 2008-04-02 20:23

Doh! Mantis "converted" the summary text so it reads wrong. See pic for what I mean.

nwa

2008-04-03 08:19

administrator   ~0001893

It's & for me, but it's because with ajax enabled, it actually converts &amp to & on the fly, non-ajax version indeed has &amp.

Amour

2008-04-04 09:10

reporter   ~0001904

Then Ajax is dirty.

DerIdiot

2008-04-05 13:38

administrator   ~0001916

anyway the reason for this is that the & are escaped in perl.
the problem is that the browser doesn't unescape it them into &.

the ajax version has some additional javascript things that turn any visual amp; into &. of course this shouldn't be needed at all.

ninjamask

2008-04-10 00:26

updater   ~0001945

another &amp problem is the episode page:

http://anidb.net/perl-bin/animedb.pl?show=ep&eid=48750

ninjamask

2008-04-21 23:44

updater   ~0001989

and also here:

http://anidb.net/perl-bin/animedb.pl?show=animelist&adb.search=w%20%26%20s

Issue History

Date Modified Username Field Change
2008-04-02 19:28 ncmaothvez New Issue
2008-04-02 19:28 ncmaothvez File Added: AmpBug.png
2008-04-02 19:31 ncmaothvez Note Added: 0001890
2008-04-02 19:32 ncmaothvez Note Edited: 0001890
2008-04-02 19:32 ncmaothvez Note Edited: 0001890
2008-04-02 19:32 ncmaothvez Note Edited: 0001890
2008-04-02 20:23 ncmaothvez Note Edited: 0001890
2008-04-03 08:19 nwa Note Added: 0001893
2008-04-04 09:10 Amour Note Added: 0001904
2008-04-05 13:38 DerIdiot Note Added: 0001916
2008-04-10 00:26 ninjamask Note Added: 0001945
2008-04-15 21:06 DerIdiot Status new => assigned
2008-04-15 21:06 DerIdiot Assigned To => DerIdiot
2008-04-21 23:44 ninjamask Note Added: 0001989
2008-05-22 17:39 DerIdiot Status assigned => resolved
2008-05-22 17:39 DerIdiot Resolution open => fixed
2008-05-24 14:45 DerIdiot Relationship added has duplicate 0001150