View Issue Details

IDProjectCategoryView StatusLast Update
0001066HTML & PERLBug Report - Interfacepublic2008-04-18 00:22
Reporterchryzaor Assigned Tofahrenheit  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001066: Search button in "addaproducer" pages always returns the same list
DescriptionWhen you edit producers for an anime, no matter what you type, the search box will always return the same huge (full?) list of producers listed in AniDB, and will reset the relation to Unknown.

Linked to http://tracker.anidb.info/view.php?id=843 ?
TagsAJAX, search

Relationships

related to 0000843 resolvedfahrenheit Can not edit Anime Producers due to a bug in the search box 

Activities

nwa

2008-04-04 20:57

administrator   ~0001908

Not quite, it doesn't do it always and it doesn't return the same list always either. When you search the first time, it'll work as intended, so you add the producer and after that you need to hit reload, then it'll search properly for the 2nd time as well. Furthermore, the full list returned is sorted by recently added/modified producers first.

In short, we've known about this bug for some time now but since it's also half ajax related and fahrenheit doesn't yet have a stable connection, it'll have to wait.

chryzaor

2008-04-05 00:08

reporter   ~0001910

Might just be some bad luck, but on my side, it happened the exact same way each time (even on first try, even after a reload). Just tested it again a minute ago, same result.

Anyway it's indeed not a major issue since it only makes the add take some more time.

fahrenheit

2008-04-06 16:20

reporter   ~0001926

let's try to clear this issue up.

If you have an ajax compatible browser (as in js enabled, xmlhttprequest, http 1.1) everything should work fine, except for some borderline cases (producer "test" fails, needs perl xml fixing), for the first time you do an add producer.
After you add a producer the page will reload, when it reloads you will notice the page url is "http://anidb.net/perl-bin/animedb.pl", as such and because the way i made the script, the scripts will not start (as intended), hence the page will do the perl version of the search, which seams to be broken to some extent.

To solve this we need to:

A) comment a line in the js producer code for it to load regardless of the url (quick&dirty solution)
B) fix the redirection (in perl, needs new release)
C) fix the perl search (needs new release)

A would be the quick solution, B and C are the correct solutions (plus fixing the xml issue).

fahrenheit

2008-04-18 00:22

reporter   ~0001975

fixed in anidb v0.1.50 (or whatever comes first)

Issue History

Date Modified Username Field Change
2008-04-04 17:45 chryzaor New Issue
2008-04-04 17:46 chryzaor Tag Attached: search
2008-04-04 20:57 nwa Note Added: 0001908
2008-04-04 20:58 nwa Tag Attached: AJAX
2008-04-05 00:08 chryzaor Note Added: 0001910
2008-04-06 12:16 DerIdiot Status new => assigned
2008-04-06 12:16 DerIdiot Assigned To => fahrenheit
2008-04-06 13:19 Rar Relationship added related to 0000843
2008-04-06 16:20 fahrenheit Note Added: 0001926
2008-04-18 00:22 fahrenheit Status assigned => resolved
2008-04-18 00:22 fahrenheit Resolution open => fixed
2008-04-18 00:22 fahrenheit Note Added: 0001975