View Issue Details

IDProjectCategoryView StatusLast Update
0001118HTML & PERLBug Report - Interfacepublic2008-07-29 21:15
ReporterHarkonnen Assigned Tofahrenheit  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001118: performing "update selected files" in mylist redirects to begining of mylist
DescriptionIn mylist in ajax mode when you click "update selected files" update is performed but also throws you to begining of mylist instead of the page you were before, and url is changed to just "http://anidb.net/perl-bin/animedb.pl", everytning that was after "?" is lost.
TagsAJAX, mylist

Relationships

duplicate of 0000802 closed Scroll to episode after viewed action in mylist 
related to 0001199 resolvedfahrenheit performing "update selected files" in mylist resets filter state 
related to 0001222 resolvedfahrenheit mylist javascript crap itself with long mylist 

Activities

Harkonnen

2008-04-26 11:39

reporter   ~0002005

actually url is changed in not ajax mode too, but you still stay on the right page.

fahrenheit

2008-04-27 13:58

reporter   ~0002008

my fault the part of it not throwing you to the page where you were, will fix this.

not the animedb.pl part, that's exp job :P

fahrenheit

2008-04-30 15:11

reporter   ~0002019

should be fixed

Harkonnen

2008-05-03 11:45

reporter   ~0002026

Last edited: 2008-05-04 17:45

not fixed :( anime that was expand stays expanded, but instead of the page you were now the entire mylist up to expanded anime is shown on a single page.

plus, i am not sure its the same issue, but if you do "edit(other)" as action, back to mylist button is clearly pointing to the beginning of mylist too

fahrenheit

2008-07-29 21:15

reporter   ~0002241

fixed as of now

Issue History

Date Modified Username Field Change
2008-04-26 11:31 Harkonnen New Issue
2008-04-26 11:31 Harkonnen Tag Attached: mylist
2008-04-26 11:31 Harkonnen Tag Attached: AJAX
2008-04-26 11:39 Harkonnen Note Added: 0002005
2008-04-27 13:58 fahrenheit Status new => assigned
2008-04-27 13:58 fahrenheit Assigned To => fahrenheit
2008-04-27 13:58 fahrenheit Note Added: 0002008
2008-04-30 15:11 fahrenheit Status assigned => resolved
2008-04-30 15:11 fahrenheit Resolution open => fixed
2008-04-30 15:11 fahrenheit Note Added: 0002019
2008-05-03 11:45 Harkonnen Status resolved => feedback
2008-05-03 11:45 Harkonnen Resolution fixed => reopened
2008-05-03 11:45 Harkonnen Note Added: 0002026
2008-05-04 17:45 Harkonnen Note Edited: 0002026
2008-05-23 00:56 fahrenheit Relationship added duplicate of 0000802
2008-07-29 20:08 fahrenheit Relationship added related to 0001199
2008-07-29 20:08 fahrenheit Relationship added related to 0001222
2008-07-29 21:15 fahrenheit Status feedback => resolved
2008-07-29 21:15 fahrenheit Resolution reopened => fixed
2008-07-29 21:15 fahrenheit Note Added: 0002241