View Issue Details

IDProjectCategoryView StatusLast Update
0000113HTML & PERLBug Report - Databasepublic2007-07-02 09:22
ReporterRarAssigned To 
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0000113: Shadow Files
DescriptionRight. You all know this baby, topic should be enough.

Basically the 'one file contains one episode' assumption at the heart of the data structure of anidb is flawed. Not only might one file contain more than one episode (Manga releases of short ova as 'movie', dual episode specials, etcetc), but also one 'episode' may be released across multiple files (generally 2/3 cd movie releases).

Shadow files would constitute a major reworking of the current data structures and interface, to allow for a more flexible file-episode relationship.

Additional InformationSome forum posts to read:
(the original thread?) http://www.anidb.net/forum/viewtopic.php?t=621
(my first post on anidb?) http://www.anidb.net/forum/viewtopic.php?t=1538
(nope, this was) http://www.anidb.net/forum/viewtopic.php?t=1499
(always around) http://www.anidb.net/forum/viewtopic.php?t=1813
(ebichu problem) http://www.anidb.net/forum/viewtopic.php?t=2671
(generics workaround issues, internal only, sorry peeps) http://www.anidb.net/forum/viewtopic.php?t=3063

EXP has been hiding from this for a long time - and with good reason, it's a major change, and in 90% of the current cases the assumption is fine. However, I feel that there are two options here. Either this gets started on soonish, as the problem with only get more painful as the database grows, or EXP acknowledges this is just too much work, and we put in place a few clear guidelines as to how generics workarounds should be used. Letting this sit mouldering on the tracker and forum much longer just isn't constructive.

Note this has been marked as a 'bug' rather than a 'feature request' as it's the source of all kinds of data problems, messy workarounds, mislabeled files, and other general chaos.
TagsNo tags attached.

Relationships

has duplicate 0000101 closed Split Movies ---> 0.5 instead of 1 file 

Activities

exp

2005-02-28 20:59

administrator   ~0000276

This is ontodo, however it will NOT be implemented in the current version of AniDB.
If a complete rewrite is ever done, this will be included from the beginning.
Untill then this feature is just too much work to be worth the trouble.

Rar

2005-02-28 21:08

reporter   ~0000281

So, do public guidelines on generic use now (basically make the results of that internal thread into a doccu thread). Then in the event of AniDB 0.6 er... a complete rewrite, this would be included from the bottom. Seems like a good solution for me. Here's hoping you have endless free time in the near future. :D

Rar

exp

2006-03-03 01:59

administrator   ~0000770

Just out of interest, which are the problems which can not be solved by the newly introduced system of additional file-to-file and file-to-ep relations?

BYe!
EXP

exp

2006-03-04 14:07

administrator   ~0000773

this point needs more feedback - is there anything left for shadow files which the newly introduced system does not address?

DerIdiot

2006-03-04 17:24

administrator   ~0000776

[ 07:06:50 ] [ @DerIdiot ] ahh i can think of another thing
[ 07:07:19 ] [ @DerIdiot ] multiep fiels that are not only part of multiple episodes, but multiple anime
[ 07:07:37 ] [ +worf ] ewww
[ 07:07:40 ] [ @DerIdiot ] happens with r1 rels merging several ova which were intended to stay split
[ 07:07:43 ] [ +worf ] yeah .. totally forgot about those
[ 07:07:56 ] [ @DerIdiot ] and baka encoder leaving it merged
[ 07:07:58 ] [ +worf ] first file that comes to mind .. MD Ghost
[ 07:08:05 ] [ @DerIdiot ] was about to say that
[ 07:08:10 ] [ @DerIdiot ] but there is more
[ 07:08:22 ] [ +worf ] yeah

yeah so basically you should be able to select the anime and the episode you want to add a relation with.

suppy

2006-03-05 13:22

reporter   ~0000779

about multi-ep relations, I gotta say that I think the percent indication is pointless - if a file has an episode in it, that's all you need - if it is not a complete episode, that is better pointed out in the file-to-file relations instead

DerIdiot

2006-03-05 22:22

administrator   ~0000780

[ 05:33:12 ] [ @EXP[BUSY] ] well, from the technical side that can easily be handled by the file-ep relations
[ 05:33:32 ] [ @EXP[BUSY] ] it's just that the current interface won't allow you to select a relation to an ep of a different anime
[ 05:33:45 ] [ @EXP[BUSY] ] or a file to file relation to a file in a different anime, for the matter
[ 05:34:10 ] [ @EXP[BUSY] ] the question here is if this is important enough to include it, makeing the interface more complicated and error prone on the way
[ 05:34:26 ] [ @EXP[BUSY] ] or if we'd rather ignore those few special cases and keep it simpler
[ 02:23:55 ] [ @DerIdiot ] [ 05:34:10 ] [ @EXP[BUSY] ] the question here is if this is important enough to include it, makeing the interface more complicated and error prone on the way <-- i don't see how this becomes "more complicated" just a field where you enter the aid. by default the aid of the anime the current file is located is set. meaning normally you don't even have to edit that field.

on another matter is it somehow possible groupentries will profit from this as well? meaning fixing the count of done episodes.

exp

2006-06-25 01:45

administrator   ~0000804

so will this issue be ready to be closed once mods can also add ep relations across animes?

DerIdiot

2006-06-25 09:11

administrator   ~0000806

should be. i can't really think about anything the "real" shadow files could do otherwise. besides being less hacky :P

Issue History

Date Modified Username Field Change
2005-02-28 17:57 Rar New Issue
2005-02-28 20:59 exp Note Added: 0000276
2005-02-28 20:59 exp Assigned To => exp
2005-02-28 20:59 exp Status new => acknowledged
2005-02-28 21:01 exp Relationship added has duplicate 0000101
2005-02-28 21:03 exp Resolution open => suspended
2005-02-28 21:08 Rar Note Added: 0000281
2006-03-03 01:59 exp Note Added: 0000770
2006-03-04 14:07 exp Note Added: 0000773
2006-03-04 14:07 exp Status acknowledged => feedback
2006-03-04 17:24 DerIdiot Note Added: 0000776
2006-03-05 13:22 suppy Note Added: 0000779
2006-03-05 22:22 DerIdiot Note Added: 0000780
2006-06-25 01:45 exp Note Added: 0000804
2006-06-25 09:11 DerIdiot Note Added: 0000806
2006-06-26 09:01 DerIdiot Status feedback => resolved
2007-07-02 09:22 epoximator Assigned To exp =>
2007-07-02 09:22 epoximator Status resolved => closed