View Issue Details

IDProjectCategoryView StatusLast Update
0001195HTML & PERLBug Report - Interfacepublic2008-08-03 21:04
Reporterkeeperofds Assigned Tofahrenheit  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001195: The "Group Status" list on the "Anime page" is not filtered by Subtitle and Audio Language preferences when using Ajax
DescriptionIf we use the following profile settings:

1. Set subtitle and audio language filters:
Languages
Subtitle Languages
english
other
Audio Languages
japanese
instrumental
other
2. Enabling or disabling the use of Ajax on the anime page with the setting "Use ajax on anime and mylist page"

Bug description:
1. Take the Anime page of Eureka 7 (it happens on all anime pages, but I take this one as an example)
http://anidb.net/a2826
2. In the "Group Status" list, when clicking on "show all"
- not using Ajax: Subtitle Languages and Audio Languages filters are applied and only groups that pass them are shown in the list
- using Ajax: Subtitle Languages and Audio Languages filters are not applied and all groups that released a file for this anime are shown

TagsNo tags attached.

Activities

keeperofds

2008-07-12 09:52

reporter   ~0002171

Last edited: 2008-07-12 09:53

Updated bug description

Bug description:
1. Take the Anime page of Eureka 7 (it happens on all anime pages, but I take this one as an example)
http://anidb.net/a2826
2. In the "Group Status" list, as shown by default
- not using Ajax: Subtitle Languages and Audio Languages filters are applied and only groups that pass them are shown in the list
- using Ajax: Subtitle Languages and Audio Languages filters are applied and only groups that pass them are shown in the list
3. In the "Group Status" list, after clicking on "show all"
- not using Ajax: Subtitle Languages and Audio Languages filters are applied and only groups that pass them are shown in the list
- using Ajax: Subtitle Languages and Audio Languages filters are NOT applied and all groups that released a file for this anime are shown

fahrenheit

2008-07-12 14:17

reporter   ~0002173

there is no bug, i made it this way because i didn't want to go change my language preferences every time i wanted to hide/show groups.

if you realy want i can add a new page pref or some such but at the moment there is no bug.

keeperofds

2008-07-12 16:51

reporter   ~0002174

In any case, the behavior is inconsistent:

- when no Ajax is used the filters are applied for both the default list and for the "show all" list
- when Ajax is used, the filters are applied only for the default list; the "show all" list doesn't have the filters applied.

It would be better to have the same behavior no matter if we use Ajax or not. Just pick one ! :)

And yes, if there could be a new page pref to toggle this behavior, that would be a nice bonus.

fahrenheit

2008-08-03 21:04

reporter   ~0002255

done, added a page preference to toggle the behaviour of the option, by default it mimics the anidb perl way (reload page to change)

Issue History

Date Modified Username Field Change
2008-07-12 09:43 keeperofds New Issue
2008-07-12 09:52 keeperofds Note Added: 0002171
2008-07-12 09:53 keeperofds Note Edited: 0002171
2008-07-12 13:54 DerIdiot Status new => assigned
2008-07-12 13:54 DerIdiot Assigned To => fahrenheit
2008-07-12 14:17 fahrenheit Note Added: 0002173
2008-07-12 16:51 keeperofds Note Added: 0002174
2008-08-03 21:04 fahrenheit Status assigned => resolved
2008-08-03 21:04 fahrenheit Resolution open => fixed
2008-08-03 21:04 fahrenheit Note Added: 0002255