View Issue Details

IDProjectCategoryView StatusLast Update
0001220HTML & PERLBug Report - Interfacepublic2008-07-28 18:17
ReporterHarkonnen Assigned Tofahrenheit  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001220: group files dont expand on first try for certain anime/group combination
DescriptionOnly in ajax mode. Steps to redproduce:
go to http://anidb.net/perl-bin/animedb.pl?show=anime&aid=5584
hit "expand this release" near Bakawolf-m33w entry
page got stuck in "please wait while loading data", javascript console has "Error: eprow has no properties
Source File: http://static.anidb.net/js/anime3/anime.js
Line: 1240"
now if you fold+expand this entry or expand any other group everything starts to work fine until you reload the page

This only happens for a very small number of anime/group combination, in addition to Special A/Bakawolf example i can only name Cooking Master Boy/A-Keep right now.


TagsAJAX, animepage

Activities

fahrenheit

2008-07-27 16:15

reporter   ~0002230

couldn't reproduce this in either firefox 2.0.0.15 nor opera 9.27, maybe it was a caching issue, try again and please state your browser.

Harkonnen

2008-07-27 16:43

reporter   ~0002232

thats very strange, i get it on any browser i tried (varios ff, seamonkey, ie6, ie7, konqueror).I even tried it from different computer on a different connection. and its on for at least a week now.

and its probably not mylist related because while i do have Bakawolf's Special A in mylist,i dont have Cooking Master Boy.

attached screenshot showing what to expand to get error

2008-07-27 16:43

 

snapshot1.png (61,578 bytes)
snapshot1.png (61,578 bytes)

fahrenheit

2008-07-27 23:08

reporter   ~0002233

like i said, can't reproduce it and if i can't do that i can't fix anything.
you could try giving me both xmls the page asks for to see if there is some problem with the generated xml's but other than that i have no idea.

Harkonnen

2008-07-28 17:09

reporter   ~0002236

this made me intrigued :), and after some investigation i finally found the culprit. its "hide parody eps on anime page" setting. if its set the described effect happens if that group made a parody ep for that anime.

fahrenheit

2008-07-28 18:17

reporter   ~0002237

thanks, that helped. fixed

Issue History

Date Modified Username Field Change
2008-07-26 22:12 Harkonnen New Issue
2008-07-26 22:12 Harkonnen Tag Attached: anime page
2008-07-26 22:12 Harkonnen Tag Attached: AJAX
2008-07-27 16:15 fahrenheit Note Added: 0002230
2008-07-27 16:43 Harkonnen Note Added: 0002232
2008-07-27 16:43 Harkonnen File Added: snapshot1.png
2008-07-27 23:08 fahrenheit Note Added: 0002233
2008-07-28 17:09 Harkonnen Note Added: 0002236
2008-07-28 18:17 fahrenheit Note Added: 0002237
2008-07-28 18:17 fahrenheit Status new => resolved
2008-07-28 18:17 fahrenheit Resolution open => fixed
2008-07-28 18:17 fahrenheit Assigned To => fahrenheit
2009-01-29 09:54 ninjamask Tag Attached: animepage
2009-01-29 09:57 nwa Tag Detached: anime page