View Issue Details

IDProjectCategoryView StatusLast Update
0001370CSSBug Report - Interfacepublic2009-07-25 01:41
ReporterHarkonnen Assigned Tofahrenheit  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001370: deprecated/invalid files no longer have red background in ajax mode
DescriptionI dont really understand how this can be, but it seems like css properties associated with invalid/deprecated class do not kick in if ajax is enabled. This is not limited to red background in anidbstyle, if any special properties is defined for invalid/deprecated files in css, they do not work in ajax mode.
TagsAJAX, animepage

Activities

fahrenheit

2009-01-24 01:57

reporter   ~0002494

my bad, was checking for deprecated status after creating the rows and setting the rows class names before checking for deprecate status :P

will be online in a couple of hours or so.

Harkonnen

2009-01-24 14:09

reporter   ~0002501

well, it marks something as deprecated now, but it misses most of the time (wrong versions), and its definitely not same files as with ajax disabled.

fahrenheit

2009-01-24 16:02

reporter   ~0002502

Last edited: 2009-01-24 16:03

It's normal that it marks different files as the non-ajax version, the deprecated rules on the ajax version are different and I don't consider that an issue.

Currently I'm using the following rules to mark files deprecated:

1:{"eusers":">=,50","fusers":"<=,3","fcrc":"!=,valid"},
2:{"fcrc":"==,invalid"},
3:{"fqual":"<=,5"}, (file quality less or equal to LOW)
4:{"c_sf_fgroup":"==,this","c_rf_fversion":"==,this","c_rf_fcrc":"==,valid","fcrc":"!=,valid","fgroup":"!=,0"},
5:{"c_sf_fgroup":"==,this","c_rf_fsource":"==,this","c_rf_fversion":">,this","c_rf_fcrc":"==,valid","fgroup":"!=,0"}}

This means that I mark a file deprecated if for the same group there's a file with the same source (DTV, HDTV, etc) and different versions, I can update the filter to mark deprectated for source and file extension.
I last updated the rule sets when we were having that issue with DTV and HDTV releases, currently the issue is with HD/HQ and SD/LQ versions of the same episode.

If you have examples of files that should be marked deprectated, please say what files and why they should be marked deprecated. I'll review that and update the rule sets if needed.
But as I said before, if the ajax version marks different files deprecated than the non-ajax version and those files are corrently marked according to my rule sets i don't see that as an issue.

If you want to read more on the ajax filters, read: http://wiki.anidb.net/w/User:Fahrenheit#Custom_filters_for_files

Harkonnen

2009-01-24 17:51

reporter   ~0002503

1st, you are not marking files which are explicitly declared as depricated (on the receiving end of newer-ver-of relation), f.e http://anidb.net/f440352

2nd, i see too obvious problems in rules:
rule 3 should exclude unknown quality (it dosnt mean file is bad, somebody was lazy when adding a file)
rule 4 should have "c_rf_fsource":"==,this" same as rule 5

updating filters too check extension would be really good also, because LQ/LD are normally done from the same HD source now and often marked as HDTV, plus there is an arising trend of making hardsubbed mp4s (ps3 compatible supposedly) alongside of mkvs.

3rd, there are a lot of files which should be deprecated according to rule 5, but for some weird reason they are not.
just some examples:
http://anidb.net/a5610, ep 27, fid 512928
http://anidb.net/a3320, ep 11, fid 235334
http://anidb.net/a6040, ep 8, fid 517527
http://anidb.net/a5674, ep 40, fid 540290

fahrenheit

2009-01-24 20:04

reporter   ~0002505

Last edited: 2009-01-24 20:13

Updated the rule sets with your comments and added a check for file extension, i'll try to check and see if it's working as expected, but i'll probably miss something (i haven't done the first bit though).

3rd, there are a lot of files which should be deprecated according to rule 5, but for some weird reason they are not.
just some examples:
http://anidb.net/a5610 ep 27, fid 512928, Is marked as deprecated
http://anidb.net/a3320 ep 11, fid 235334, Is marked as deprecated
http://anidb.net/a6040 ep 8, fid 517527, Is marked as deprecated
http://anidb.net/a5674 ep 40, fid 540290, Is marked as deprecated

1st, you are not marking files which are explicitly declared as depricated (on the receiving end of newer-ver-of relation), f.e http://anidb.net/f440352

This was being marked as deprecated also. Though i admit that i don't explicitly check for newer-ver-of relations, mostly because no one uses that relation and just changing the version number is easier.

Maybe your browser was using a cached version of the scripts?

Never the less, if ignoring that last fact about not checking for newer-ver-of rels, do you have any more issues or can i close the issue?

Harkonnen

2009-01-24 22:21

reporter   ~0002508

Uh.. I am sorry, i was too lazy to run dom inspector before posting previous note. The problem with that files is not about being marked deprecated, but that you generated html have something like that <tr class="good verified deprecated g_odd". Obviously, "g_odd" bacgkround color takes precedence over "deprecated" (and firefox which i use always ignored "text decoration:line-through" on anidb for some odd reason), so it looked like "odd" files are not deprecated.

You should put g_odd first in class declarations.

fahrenheit

2009-01-24 22:56

reporter   ~0002509

actualy the issue wasn't that, it was the "good" class name, I'll put a fixed version online in a couple of hours or so.

fahrenheit

2009-01-27 21:18

reporter   ~0002518

files should now also be deprecated based on "newer-ver-of" relations.

i'm closing this issue unless some extra breakage is indicated.

Issue History

Date Modified Username Field Change
2009-01-04 12:56 Harkonnen New Issue
2009-01-04 12:56 Harkonnen Tag Attached: AJAX
2009-01-04 12:56 Harkonnen Tag Attached: anime page
2009-01-06 22:27 worf Status new => assigned
2009-01-06 22:27 worf Assigned To => fahrenheit
2009-01-24 01:57 fahrenheit Status assigned => resolved
2009-01-24 01:57 fahrenheit Resolution open => fixed
2009-01-24 01:57 fahrenheit Note Added: 0002494
2009-01-24 14:09 Harkonnen Status resolved => feedback
2009-01-24 14:09 Harkonnen Resolution fixed => reopened
2009-01-24 14:09 Harkonnen Note Added: 0002501
2009-01-24 16:02 fahrenheit Note Added: 0002502
2009-01-24 16:02 fahrenheit Note Edited: 0002502
2009-01-24 16:02 fahrenheit Note Edited: 0002502
2009-01-24 16:03 fahrenheit Note Edited: 0002502
2009-01-24 16:03 fahrenheit Note Edited: 0002502
2009-01-24 17:51 Harkonnen Note Added: 0002503
2009-01-24 20:04 fahrenheit Note Added: 0002505
2009-01-24 20:13 fahrenheit Note Edited: 0002505
2009-01-24 22:21 Harkonnen Note Added: 0002508
2009-01-24 22:56 fahrenheit Note Added: 0002509
2009-01-27 21:18 fahrenheit Note Added: 0002518
2009-01-27 21:18 fahrenheit Status feedback => resolved
2009-01-27 21:18 fahrenheit Resolution reopened => fixed
2009-01-29 09:54 ninjamask Tag Attached: animepage
2009-01-29 09:57 nwa Tag Detached: anime page
2009-07-25 01:41 DerIdiot Project HTML & PERL => CSS