View Issue Details

IDProjectCategoryView StatusLast Update
0001397AJAX/JSFeature Request - Interfacepublic2016-04-17 02:16
Reporternwa Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001397: some improvements for "add file relation" page
DescriptionIt's not easy to get any more user-friendly than the current interface for file relations. Mods have it easy as they can simply paste the fid and be done with it, but selecting the correct file from within ALL the files added to the anime is a tad tedious.

Globally
It would be nice if only files from within the same group are displayed, if file is no group, well then all the no group files.

newer-ver-of
When newer-ver-of relation is selected, the files should be filtered even more, down to only files from within the same episode the current file is added under (unless someone can give me cases where newer version file was added under a different episode, but mods can take care of that with the fid field) as well as only files with version number lower than the current file. It would furthermore help to see source and resolution for the selectable video files as well as for the current file.

bundle, op/end-for
When bundle or op/end-for is selected, it'd be nice to be able to select more than 1 file, dropdown menu for this would then be out of the question I suppose.

Guess this one is for fahry and his AJAX magic, huh?
TagsAJAX, file

Activities

fahrenheit

2009-01-28 20:44

reporter   ~0002526

there's already a lot of js magic there :P
try that page with js disabled :P

nwa

2009-01-28 20:57

administrator   ~0002527

I tried, didn't see the difference - Javascript: anime3/addfilerel.js $Revision: 1900 was always loaded.
Btw, I was being sarcastic with my first sentence in the description :P

fahrenheit

2009-01-28 21:56

reporter   ~0002528

you are blind!

http://static.anidb.net/tmp/js_enabled.jpg
vs.
http://static.anidb.net/tmp/js_disabled.jpg

anyways, the current script already does almost everything it can without breaking massively if I try to fectch data (which i can't, it's too much data for most animes).

Stuff done by the script now:

* filters relations types based on the current file
* filters the related file list based on relation type (ie, if the current file is a subtitle file and the relation type is external-sub-for, the filelist will be filtered down only to file types that accept that relation, in the specific case, video files)

Okay, now for your wishlist, I'll comment on the doability of each request:

Globally
It would be nice if only files from within the same group are displayed, if file is no group, well then all the no group files.

You are forgetting that subtitle files usualy have no group, following your logic I would most probably filter out all video files, but ignoring the no group part, this one is okay to do, but will probably increase the file list to include GID info:

EP 1 - FID 1101 - TYPE video file
vs
EP 1 - FID 1101 - GID 1 - TYPE video file

newer-ver-of
When newer-ver-of relation is selected, the files should be filtered even more, down to only files from within the same episode the current file is added under (unless someone can give me cases where newer version file was added under a different episode, but mods can take care of that with the fid field) as well as only files with version number lower than the current file. It would furthermore help to see source and resolution for the selectable video files as well as for the current file.

For this case i can fetch ep+group data, so this one is okay.

bundle, op/end-for
When bundle or op/end-for is selected, it'd be nice to be able to select more than 1 file, dropdown menu for this would then be out of the question I suppose.

Dropdown is not out of the question but I don't think it's worth the effort, so this one is denied :P

fahrenheit

2009-01-29 20:16

reporter   ~0002534

<nwa> let me think
<nwa> still can't see the difference between a HD and SD release
<nwa> or DVD and DTV release
<fahrenheit> hmm
<fahrenheit> that may be a major issue
<fahrenheit> i can load everything by ajax (i managed to do your two requests without that)
<fahrenheit> but the page will probably break for never ending anime?
<fahrenheit> want me to try?
<nwa> why would it break?
<fahrenheit> too much data to process
<fahrenheit> will probably trigger browsers, this script is borked warnings
<fahrenheit> hmm
<fahrenheit> or i can change the perl
<nwa> hmm, would be nice to have at least the resolution seen
<fahrenheit> the drop down for type stays
<nwa> wouldn't quite even need anything else
<fahrenheit> but the drop down for files would be replaced by a filelist
<fahrenheit> like in mylist when you choose "Show fileinfo" where the episode number is also shown
<nwa> that'd be even better
<fahrenheit> kay, i'll put that on todo
<nwa> but this is only needed for new version relation
<nwa> not for anything else
<fahrenheit> yeah, but if i do that i'll also do the other request you asked
<fahrenheit> the choose multiple stuff thing
<nwa> ah the multi select
<nwa> well, yeah, that'd definitely be good as well
<fahrenheit> js on this new aproach would filter the filelist just like the combo box
<fahrenheit> otherwise the perl will get no filtering

zeromind

2009-03-04 02:21

reporter   ~0002585

ok, there seems to be quite an issue with the current filtering; if a group releases an external sub file for a raw/no group file, you'll end up with no files to add a relation for

fahrenheit

2009-03-04 02:26

reporter   ~0002586

could you please give an example zero?

affected file and group

zeromind

2009-03-04 02:33

reporter   ~0002587

Last edited: 2009-03-04 02:37

http://anidb.net/f554994 sub for -> http://anidb.net/f555521
group: zerimond http://anidb.net/g5073
*cough*

DerIdiot

2016-04-17 02:16

administrator   ~0003747

the addfilefilerel page has a filterable/searchable select list for about a month now. that should be good enough to get a desired result. better than auto filtering stuff and then failing on corner cases

Issue History

Date Modified Username Field Change
2009-01-28 20:22 nwa New Issue
2009-01-28 20:44 fahrenheit Note Added: 0002526
2009-01-28 20:45 fahrenheit Status new => assigned
2009-01-28 20:45 fahrenheit Assigned To => fahrenheit
2009-01-28 20:57 nwa Note Added: 0002527
2009-01-28 21:56 fahrenheit Note Added: 0002528
2009-01-29 11:10 nwa Tag Attached: AJAX
2009-01-29 11:10 nwa Tag Attached: file
2009-01-29 20:16 fahrenheit Note Added: 0002534
2009-01-29 20:16 fahrenheit Status assigned => acknowledged
2009-03-04 02:21 zeromind Note Added: 0002585
2009-03-04 02:26 fahrenheit Note Added: 0002586
2009-03-04 02:33 zeromind Note Added: 0002587
2009-03-04 02:37 zeromind Note Edited: 0002587
2009-07-24 14:03 DerIdiot Project HTML & PERL => AJAX/JS
2016-02-09 23:22 DerIdiot Status acknowledged => new
2016-02-09 23:26 DerIdiot Assigned To fahrenheit =>
2016-04-17 02:16 DerIdiot Note Added: 0003747
2016-04-17 02:16 DerIdiot Status new => resolved
2016-04-17 02:16 DerIdiot Resolution open => fixed
2016-04-17 02:16 DerIdiot Assigned To => DerIdiot