View Issue Details

IDProjectCategoryView StatusLast Update
0000203HTML & PERLFeature Request - Databasepublic2007-12-06 08:29
Reporterrowaasr13 Assigned Toexp  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000203: Force all chars in input to be inside <127 range
DescriptionGeneral idea is that all strings inside database must be low-ASCII (<127) to prevent problems that different software used on AniDB could have. UTF8 to HTML cleaner is good solution to ensure that there's nothing but low ASCII in it, but sometimes people don't use it because they don't even know that symbols like ellipsis are outside this range or rely on browser's automatical conversion of input to HTML entities for symbols that are outside current encoding, which is not sufficient, since iso-8859-1, default encoding on AniDB, includes some >127 symbols, not to mention cases when user's browser is set to something else because auto-detection or something like that.

Some other funny effects include converting … to ellipsis by browser and then, when user submits creq, submiting it back as literal symbol, as it is valid under iso-8859-1 - codepage that is used by AniDB web UI. See http://anidb.info/perl-bin/animedb.pl?show=creq&do.showhist=1&nonav=1&creq.id=149370 for example of such change.

Therefore, I think that all input should be checked and if there are any >127 symbols in it, user must get error message, telling him to use converter. Optionally, some common literal symbols replacement could be done automatically, like mentioned ? to &#8230 and some others that common user don't see as "non-standard".
TagsNo tags attached.

Activities

exp

2005-06-08 21:48

administrator   ~0000509

might be a good workaround until we change to utf8

Issue History

Date Modified Username Field Change
2005-06-08 09:24 rowaasr13 New Issue
2005-06-08 21:48 exp Note Added: 0000509
2005-06-08 21:48 exp Assigned To => exp
2005-06-08 21:48 exp Status new => acknowledged
2006-07-23 18:02 DerIdiot Status acknowledged => resolved
2007-12-06 08:29 epoximator Resolution open => fixed