View Issue Details

IDProjectCategoryView StatusLast Update
0002694HTML & PERLBug Report - Interfacepublic2017-07-20 14:18
ReporterCDB-Man Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in Version2017-08 
Summary0002694: Forum Post Notify: Missing Parent Forum Name for Posts to AGID Comments
DescriptionA new post here:
https://anidb.net/perl-bin/animedb.pl?show=cmt&id=55948#c416994

Resulting message:
https://anidb.net/perl-bin/animedb.pl?show=msg&do.show=1&mid=3254245

This was the subject of the PM:
[NOTIFICATION] FORUM - new post in thread: [] comments

Note the missing parent forum name in the empty [].
TagsNo tags attached.

Activities

Hinoe

2016-11-02 11:45

reporter   ~0003911

I'll note that both anime and group names need to be included there, otherwise it's sort of misleading (the immediate parent alone would have you think that it's the comments for the anime entry).

CDB-Man

2017-06-11 02:30

manager   ~0004031

Last edited: 2017-06-11 02:31

View 2 revisions

Hmm, looking at https://anidb.net/perl-bin/animedb.pl?show=msg&do.show=1&mid=3357811 I can see that this part of the message title is removed:
>> [NOTIFICATION] FORUM - new post in thread:

And the title is now this instead:
>> Test Group - Test Anime

Current implementation is slightly misleading as it doesn't specify it's a forum or comment (ie it kinda reads like a notification of a file release or something. IMO the title should be:
>> [NOTIFICATION] FORUM - new post in thread: Test Group - Test Anime

Hinoe

2017-06-11 15:09

reporter   ~0004035

Ideally all forum-related PM titles should be standard, and anime/group/animegroup/etc should have the full path:

Anime > $AnimeName > $ThreadName
Blogs > $UserName > $ThreadName
Clubs > $ClubName > $ThreadName
Releases > $GroupName > General Group Talk > $ThreadName
Releases > $GroupName > $AnimeName > $ThreadName
$AnyOtherForum > $ThreadName

All those forums support both comments threads (each with their own specific names) and regular threads; this makes all relevant parts clear and also disambiguates between e.g. anime and their clubs if they happen to have the same name.

IMO the "[NOTIFICATION]" part is sort of redundant; the whole thing can become e.g.:

[FORUM] new post in thread: Anime > $AnimeName > $ThreadName

I would also recommend using > instead of - because - is a common name part separator, making it potentially confusing.

I'm not sure how reviews comments are handled (if at all), but, assuming there can be only one thread (otherwise, add thread name as well) they could be:

Reviews > $UserName > $AnimeName

Then again, it might be interesting to handle reviews separately instead as of regular threads, so there's that. Speaking strictly, I would prefer review comments to not be limited to one per person and tied to the vote, instead making review comments like a regular thread, but whatever.

Issue History

Date Modified Username Field Change
2016-11-01 20:31 CDB-Man New Issue
2016-11-02 11:45 Hinoe Note Added: 0003911
2016-11-24 14:46 DerIdiot Assigned To => DerIdiot
2016-11-24 14:46 DerIdiot Status new => resolved
2016-11-24 14:46 DerIdiot Resolution open => fixed
2016-11-24 14:46 DerIdiot Fixed in Version => 2016-12
2017-06-11 02:30 CDB-Man Status resolved => feedback
2017-06-11 02:30 CDB-Man Resolution fixed => reopened
2017-06-11 02:30 CDB-Man Note Added: 0004031
2017-06-11 02:31 CDB-Man Note Edited: 0004031 View Revisions
2017-06-11 15:09 Hinoe Note Added: 0004035
2017-07-20 14:17 DerIdiot Status feedback => resolved
2017-07-20 14:17 DerIdiot Resolution reopened => fixed
2017-07-20 14:18 DerIdiot Fixed in Version 2016-12 => 2017-08