View Issue Details

IDProjectCategoryView StatusLast Update
0002740AJAX/JSFeature Request - Interfacepublic2016-12-14 06:52
ReporterCDB-Man Assigned ToDerIdiot  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Fixed in Version2017-01 
Summary0002740: bbcode editor: image popup improvements
Description1) Related to: https://tracker.anidb.net/view.php?id=2737 -- looks like image tags were missed, they should also have the cursor exit the block as well.

2) if the user has text highlighted that matches an image link, then the popup shouldn't appear, and it should just parse the image link and exit the block

Ie if https://i.imgur.com/MBrNWyv.jpg is selected, skip the popup and exit the cursor from the block.
TagsNo tags attached.

Relationships

related to 0002737 resolvedDerIdiot bbcode editor: URL popup, cursor position upon submitting popup 

Activities

DerIdiot

2016-12-07 09:36

administrator   ~0003944

not going to happen

CDB-Man

2016-12-07 13:18

manager   ~0003945

I assume you just mean that 2) isn't going to happen to which I have no objection -- 1) should still be fixed.

Hinoe

2016-12-07 13:23

reporter   ~0003946

But why not? The suggested behavior is, for all intents and purposes, the one from the old bbcode editor, and I doubt that any user on their right mind would consider the current behavior an improvement over the previous one. If anything, I imagine that most reasonable users would consider it a misfeature, if not an outright bug.

The previous behavior is easier and more intuitive, it was already in place, and it is standard across forum software everywhere. The current behavior loses in all those aspects, and has nothing going in its favor. Reverting to a behavior that is clearly superior, from the perspectives of usability or user-friendliness, seems like a good idea to me.

If the issue is the need to check whether the selected text matches an image link, that should definitely be waived, yes, as there's no way to make sure a link corresponds to an image one way or another.

Hinoe

2016-12-07 13:28

reporter   ~0003947

For context: I didn't see CDB's reply before writing my own, and this inability to edit notes is annoying like you wouldn't believe.

As far as 2 is concerned, skipping the popup when there's text selected should still happen. If the user hits the image button upon selecting text, what else might they be linking to, if not an image? If they're inserting what isn't an image, the popup won't fix it, and neither does it have any reason to.

Issue History

Date Modified Username Field Change
2016-12-07 04:27 CDB-Man New Issue
2016-12-07 04:32 CDB-Man Relationship added related to 0002737
2016-12-07 04:33 CDB-Man Description Updated View Revisions
2016-12-07 09:36 DerIdiot Note Added: 0003944
2016-12-07 13:18 CDB-Man Note Added: 0003945
2016-12-07 13:23 Hinoe Note Added: 0003946
2016-12-07 13:28 Hinoe Note Added: 0003947
2016-12-08 12:27 DerIdiot Assigned To => DerIdiot
2016-12-08 12:27 DerIdiot Status new => resolved
2016-12-08 12:27 DerIdiot Resolution open => fixed
2016-12-08 12:27 DerIdiot Fixed in Version => 2017-01