View Issue Details

IDProjectCategoryView StatusLast Update
0002791HTML & PERLFeature Request - Interfacepublic2017-08-21 22:46
ReporterHinoe Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0002791: show=addcharanimerel&charid=XYZ missing restricted class for 18+ anime
DescriptionAs the summary says. See e.g. https://anidb.net/perl-bin/animedb.pl?show=addcharanimerel&charid=53303

Tropical Kiss https://anidb.net/a9347 is marked 18+, but it's missing the restricted class in the addcharanimerel page above.

It probably makes little sense to mark the chars in the &aid=XYZ counterpart, so only adding it to the &charid=XYZ version of the page should be enough.
TagsNo tags attached.

Activities

DerIdiot

2017-08-21 15:40

administrator   ~0004099

"g_image g_bubble thumbcrop restricted" looks fine to me

Hinoe

2017-08-21 22:40

reporter   ~0004102

The class is implemented on <tr> as well pretty much everywhere else, and that's what the request was about. I didn't even know that it also existed on the pics until today.

https://anidb.net/perl-bin/animedb.pl?show=addcharanimerel&charid=53303 <-- "restricted" is only in the pic; <tr> is just <tr class="g_odd">

https://anidb.net/ch53303 has:
Under "Related Anime": <tr role="row" id="charanimerelid_75963" class="restricted"> [...] <img (stuff) class="g_image g_bubble thumbcrop restricted">
Under "Seiyuu": <td class="name anime restricted">

Hinoe

2017-08-21 22:46

reporter   ~0004103

Under "Seiyuu" in the char page, make what I said:
<td class="name anime restricted"> [...] </td>
<td class="type restricted"> [...] </td>
<td class="ismainseiyuu restricted"> [...] </td>
<td class="comment restricted"> [...] </td>

In other words, every <td> tag corresponding to the anime (because the <tr> tag itself spans multiple anime in that table).

Issue History

Date Modified Username Field Change
2017-01-18 19:20 Hinoe New Issue
2017-08-21 15:40 DerIdiot Assigned To => DerIdiot
2017-08-21 15:40 DerIdiot Status new => closed
2017-08-21 15:40 DerIdiot Resolution open => no change required
2017-08-21 15:40 DerIdiot Note Added: 0004099
2017-08-21 22:40 Hinoe Status closed => feedback
2017-08-21 22:40 Hinoe Resolution no change required => reopened
2017-08-21 22:40 Hinoe Note Added: 0004102
2017-08-21 22:46 Hinoe Note Added: 0004103
2017-08-21 22:46 Hinoe Status feedback => assigned