View Issue Details

IDProjectCategoryView StatusLast Update
0003122AJAX/JSBug Report - Interfacepublic2019-08-08 16:28
ReporterSoulweaver Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-01 
Summary0003122: Quicksearch: Suggestions for song searches don't appear
DescriptionIt appears that the list fails to populate because the JS tries to look up nonexistent images for the songs:

TypeError: i.picurl is undefined

It seems to be the only resource type that both has suggestions enabled in the quicksearch (why don't they all have?) and that has this problem.
TagsNo tags attached.

Activities

DerIdiot

2018-12-04 17:01

administrator   ~0004312

can't reproduce

Soulweaver

2018-12-04 18:03

reporter   ~0004313

Okay, went back to do some actual debugging and it seems it is a HTTPS specific issue. There's a bit that converts the link/image URLs' protocols of the API response from http to https when on the https site, and it doesn't check if the picurl is actually defined. Of course, it never branches there on http so it doesn't throw on that side. Line 4061 on current master (heh, after looking it up down to the exact spot, I could've just committed the fix myself I guess :D)

Issue History

Date Modified Username Field Change
2018-02-04 19:32 Soulweaver New Issue
2018-12-04 17:01 DerIdiot Assigned To => DerIdiot
2018-12-04 17:01 DerIdiot Status new => feedback
2018-12-04 17:01 DerIdiot Note Added: 0004312
2018-12-04 18:03 Soulweaver Note Added: 0004313
2018-12-04 18:03 Soulweaver Status feedback => assigned
2018-12-05 01:49 DerIdiot Status assigned => resolved
2018-12-05 01:49 DerIdiot Resolution open => fixed
2018-12-05 01:49 DerIdiot Fixed in Version => 2019-01