View Issue Details

IDProjectCategoryView StatusLast Update
0003128HTML & PERLFeature Requestpublic2019-08-08 16:26
Reporterjosi Assigned ToDerIdiot  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2018-09 
Summary0003128: Massadd Episodes: reordering episodes for normal users
DescriptionWhen I want to add several variants of the endings of One Room (https://anidb.net/a12550) using the 'Add/edit Episodes' button, I always get an Internal Server Error (with no further information).
Additional InformationA screenshot of what exactly I'm trying to submit attached.
TagsNo tags attached.

Activities

josi

2018-02-10 12:12

reporter  

Hinoe

2018-02-10 14:29

reporter   ~0004193

You're trying to move existing episodes and add new episodes to use the numbers of the ones you moved, aren't you? As in, from what I can tell, you're e.g. moving C2 to C5 and adding a new C2.

Unless you can owneredit all the involved episodes, you can't do that without at least ep maintainer powers. As user, you need to creq the move, and you're only able to add a new episode AFTER that's granted and the number is freed.

In those cases, you're supposed to add the new ones at the end of the list and creq an already existing ep to another position; in the creq, you should explain what changes are necessary and what the list should look like, so that the handling mod can shift the episodes around accordingly.

I would say that a more useful error message would be called for, though. So the behavior of failing is intended, but the lack of a message explaining the problem is a bug.

josi

2018-02-11 07:45

reporter   ~0004194

Thanks for the explanation, makes sense.

DerIdiot

2018-08-30 10:24

administrator   ~0004273

normal user can reorder episodes now via creq

Issue History

Date Modified Username Field Change
2018-02-10 12:12 josi New Issue
2018-02-10 12:12 josi File Added: Screenshot_2018-02-10_13-04-21.png
2018-02-10 14:29 Hinoe Note Added: 0004193
2018-02-11 07:45 josi Note Added: 0004194
2018-08-30 10:24 DerIdiot Category Bug Report => Feature Request
2018-08-30 10:24 DerIdiot Summary Internal Server Error when mass editing episodes => Massadd Episodes: reordering episodes for normal users
2018-08-30 10:24 DerIdiot Assigned To => DerIdiot
2018-08-30 10:24 DerIdiot Status new => resolved
2018-08-30 10:24 DerIdiot Resolution open => fixed
2018-08-30 10:24 DerIdiot Fixed in Version => 2018-09
2018-08-30 10:24 DerIdiot Note Added: 0004273