View Issue Details

IDProjectCategoryView StatusLast Update
0003403HTML & PERLBug Report - Interfacepublic2020-01-18 12:49
ReporterAnnoun Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003403: Do not show character tags marked as spoilers in anime page
Description

If an anime tag is a spoiler, it is not shown on the Anime Tags tab of the anime page.

The behaviour should be the same for character tags marked as spoilers: They should not appear on the Character Tags tab if the user has “Show tags marked as spoiler” disabled.

Steps To Reproduce
  1. Disable “Show tags marked as spoiler” in Settings → Global Settings.

  2. Browse to an anime page for which at least one character in the cast has a tag applied that is marked as a spoiler. Example: https://anidb.net/a10569

  3. All tags marked as spoilers are listed in the Character Tags tab.
Additional Information

The severity of this issue is reduced since it is usually not immediately obvious to which character a tag applies from the view on the Character Tags tab, and the spoiler tags are properly hidden in the Cast tab. However, the presence of such tags can still be a spoiler in itself (e.g., a “time traveller” tag in an anime where there being time travelling is a spoiler), or it can become evident before intended to which character a spoiler tag applies as one watches the anime (e.g., “artificial life form” is a likely explanation as to why a character has no memories of their childhood).

Tagsanimepage, character tags

Activities

DerIdiot

2020-01-17 15:17

administrator   ~0004411

that is already the case and works just fine.

Announ

2020-01-18 01:13

reporter   ~0004412

In the "Character Tags" section of <a href="https://anidb.net/a1563">the anime page of CITY HUNTER 2</a>, I see 2 "fetish appeals" tags—"cross-dressing" and "reverse trap"—that come from https://anidb.net/ch88660, on which they are marked as "Spoiler for this entry?". I have "Show tags marked as spoiler" disabled and do not have any episode of that anime in my list.

Announ

2020-01-18 01:16

reporter  

anime_1563.png (43,992 bytes)
anime_1563.png (43,992 bytes)
character_88660_tag.png (18,068 bytes)
character_88660_tag.png (18,068 bytes)

Issue History

Date Modified Username Field Change
2020-01-09 15:00 Announ New Issue
2020-01-09 15:00 Announ Tag Attached: animepage
2020-01-09 15:00 Announ Tag Attached: character tags
2020-01-10 06:46 DerIdiot Project AniDB Website => HTML & PERL
2020-01-17 15:17 DerIdiot Note Added: 0004411
2020-01-17 15:18 DerIdiot Assigned To => DerIdiot
2020-01-17 15:18 DerIdiot Status new => closed
2020-01-17 15:18 DerIdiot Resolution open => no change required
2020-01-18 01:13 Announ Status closed => feedback
2020-01-18 01:13 Announ Resolution no change required => reopened
2020-01-18 01:13 Announ Note Added: 0004412
2020-01-18 01:16 Announ File Added: anime_1563.png
2020-01-18 01:16 Announ File Added: character_88660_tag.png
2020-01-18 12:49 DerIdiot Status feedback => resolved
2020-01-18 12:49 DerIdiot Resolution reopened => fixed