View Issue Details

IDProjectCategoryView StatusLast Update
0003431AJAX/JSBug Report - Interfacepublic2020-04-16 14:58
ReporterCDB-Man Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003431: Profile settings: collision between Title Language dropdowns and Personal Data First Anime Dropdown
DescriptionOn Default Languages > Anime Language dropdown, "Pocket Monsters" is listed as a language option.

This appears related to the fact that on Personal Data > First Anime, my first anime is "Pocket Monsters". See screenshot.

12:23:49 CDB-Work> uh, worf, in the https://anidb.net/user/setting default languages tab, anime language dropdown, there's an option in the list for "Pocket Monsters"???
12:24:52 &pelican> Pika?
12:25:57 CDB-Work> and sometimes if you refresh, it shows in teh Episode Title dropdown instead
12:26:09 CDB-Work> Episode Language*
13:25:38 &worf> errr
13:25:44 &worf> what are you even talking about
13:50:33 CDB-Work> worf: https://i.imgur.com/52QVpwB.png
14:25:26 &worf> yeah .. no
14:25:42 &worf> are you 100% certain this isnt some stupid userscript you are running?
14:25:57 CDB-Work> its on work computer, so 0 scripts
14:26:48 CDB-Work> the only thing i can think of
14:26:54 CDB-Work> is in the Personal Data tab
14:26:59 CDB-Work> my first anime is Pocket Monsters
14:27:37 &worf> gimme a sec
14:27:47 &worf> lol
14:27:50 &worf> ok, thats cute
14:27:52 CDB-Work> yeah?
14:27:56 CDB-Work> what did you find?
14:28:04 &worf> that is indeed the cause
14:28:33 &worf> funnily enough, i can only reproduce it in Firefox .. not in the new Edge
14:29:01 CDB-Work> im in Chrome
14:29:31 CDB-Work> new Edge uses chromium engine right? in any case, even in chrome it is not consistent, only happens some of the time
14:30:05 CDB-Work> so now that you know the issue, is it the library's issue or something we can fix lol
14:31:31 &worf> js isnt really my forte ... my best guess at the moment is a naming collision
14:34:51 &pelican> For some reason I thought race conditions wouldn't generally happen in js, I guess they do
14:40:12 &worf> ...
14:40:32 &worf> i saw the damn entry in the dom for a second .. then i reloaded the page and now i cant find it again
14:42:32 &worf> this is definitely some weird js issue
14:42:46 &worf> there was a wrong dropdown element in the language list
TagsNo tags attached.

Activities

CDB-Man

2020-04-15 18:44

manager  

Capture.PNG (45,048 bytes)
Capture.PNG (45,048 bytes)

DerIdiot

2020-04-16 14:58

administrator   ~0004423

probably fixed .... maybe

Issue History

Date Modified Username Field Change
2020-04-15 18:44 CDB-Man New Issue
2020-04-15 18:44 CDB-Man File Added: Capture.PNG
2020-04-16 14:58 DerIdiot Assigned To => DerIdiot
2020-04-16 14:58 DerIdiot Status new => resolved
2020-04-16 14:58 DerIdiot Resolution open => fixed
2020-04-16 14:58 DerIdiot Note Added: 0004423