View Issue Details

IDProjectCategoryView StatusLast Update
0000452HTML & PERLFeature Request - Interfacepublic2006-11-02 21:28
ReporterGambit Assigned Toepoximator  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000452: review ability only if an anime is finished / Previews / flagging of reviews of people who haven't seen the complete series
Descriptionproblem is the following. people who haven't seen the complete series are reviewing series. that's hardly objective.

there were various approaches suggested to fix this "problem"

- don't allow reviewing until the series is over
- a box added for each review with "i watched all eps" reviews get ordered according to the setting and user can possibly disable seeign "incomplete reviews"
- preview section additional to the review one. basically a clone of the review system called preview where the tards cna post as much as they want
this would also need the ability for mods to shift reviews between the 2 sections.
Additional Informationmore in detail explanations here:
http://www.anidb.net/forum/viewtopic.php?t=1206
TagsNo tags attached.

Relationships

duplicate of 0000520 closed Able to Review an Anime when all episodes not released 
has duplicate 0000536 closed Add an "Initial Impressions" section, similar to the reviews section, where people can give their early impressions on an anime. 

Activities

DonGato

2006-07-21 20:48

reporter   ~0000872

I'm for the first option.

fahrenheit

2006-07-21 23:24

reporter   ~0000887

Last edited: 2006-07-22 05:58

1 is easy to implement, or at least easy to trow some sand and in the users eyes and remove the review link, this could be achived by only allowing review after the end date (or at least after a given set of episodes if end date isn't known).

as for 2 and 3 , they are basicaly the same, you just need to flag a review that is done before anime completion and let the review page for an anime take care of hiding the incomplete reviews if the user so wants to in his/her profile, this could be easily done without js, mods would only have the special ability to mark a particular review as done after completion or not.

in my opinion we could have all your sugestions at once without problem and without much work for exp (i'm guessing about 3 new lines of code at and 1 new user pref)

Gambit

2006-07-26 09:28

reporter   ~0000913

Last edited: 2006-07-26 09:31

1 looks pretty useful already. That will keep the majority of morons away since they can`t review until the show finishes. This sounds the easiest to do, really.

2 is very useful imho, especially when setting that flag that you do not want to see incomplete reviews. The drawback here is that reviewers don`t always update their mylist, so linking to the userlist might be a bit hard unless you make them update their mylist.

3 is an idea of myself, iirc where I opted for a new link where you can add previews. This is useful for all the people who don`t want to write a review at the end of a show, but want to speak up what they thought about the series after having seen 1-3 eps. I often see people posting those in the reviews where they don`t belong. Luckily the current system gets them downrated all the time.

- fahrenheit: I don`t think the current mods are really waiting for another option where they need to 'move' previews to become reviews. If you want that implemented, you should automate it. But that means that the 'move' would only have to be made after the show has ended AND the preview has been edited to reflect all changes made to the review based on the rest of the series.
It`ll also have to rely heavily on people editing the dates; I`m not sure how fanatic people are to do so now.

epoximator

2006-11-02 12:53

reporter   ~0001095

Last edited: 2006-11-03 09:47

1. done

Issue History

Date Modified Username Field Change
2006-07-21 17:15 DerIdiot New Issue
2006-07-21 20:48 DonGato Note Added: 0000872
2006-07-21 23:24 fahrenheit Note Added: 0000887
2006-07-21 23:25 fahrenheit Note Edited: 0000887
2006-07-22 05:27 DerIdiot Reporter DerIdiot => Gambit
2006-07-22 05:58 DerIdiot Note Edited: 0000887
2006-07-26 09:28 Gambit Note Added: 0000913
2006-07-26 09:31 Gambit Note Edited: 0000913
2006-09-30 19:30 DerIdiot Relationship added duplicate of 0000520
2006-10-20 03:19 DerIdiot Relationship added has duplicate 0000536
2006-11-02 12:53 epoximator Note Added: 0001095
2006-11-02 12:53 epoximator Assigned To => epoximator
2006-11-02 12:53 epoximator Status new => acknowledged
2006-11-02 21:28 epoximator Status acknowledged => resolved
2006-11-02 21:28 epoximator Resolution open => fixed
2006-11-03 09:47 epoximator Note Edited: 0001095