View Issue Details

IDProjectCategoryView StatusLast Update
0000050HTML & PERLBug Report - Databasepublic2007-12-06 08:29
ReporterDonGato Assigned Toexp  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000050: DB Entries contain invalid character codes
DescriptionSome DB entries contain non-html encoded special characters which are not displayed correctly.
Possible solution: run a script over all DB entries which converts such characters into their html encoded counterparts.

Old Req:
While browsing with FireFox the anime Turn A (and some others) the page encoding used in AniDB (iso-8859-1) shows some strange characters for episodes and description. This isn't only related to FireFox; the same happens with IE and Opera. Shouldn't the encoding be changed to UTF-8 or some sort of escaping for the wrong characters be made?

Link to anime: http://anidb.ath.cx/perl-bin/animedb.pl?show=anime&aid=916
Additional InformationProblem: the counterpart for some characters may be undefined because it can no longer be determined which encoding was used when they were entered.
TagsNo tags attached.

Activities

DonGato

2005-01-06 14:37

reporter   ~0000101

It seems I misunderstood the problem. The problem is a wrong character that seems to have been left from some old encoding style. Couldn't this be fixed by a process over the database?

exp

2005-01-07 17:31

administrator   ~0000103

yes, and this in ONTODO, however, it doesn't have a high priority so far.

exp

2005-01-07 17:32

administrator   ~0000104

btw. if you change this request accordingly I'll be happy to change it's state to ONTODO too :P

DonGato

2005-01-07 19:43

reporter   ~0000105

The problem is I don't have the rights to change it :(

DonGato

2005-01-09 12:23

reporter   ~0000118

I must state that the most common mistake is the one visible in Turn-A Gundam episodes about the ' (apostrophe).

Amour

2005-01-19 07:43

reporter   ~0000147

I've often submitted corrections about those apostrophes.
You could just make creq for each episode and it will be solved.

Issue History

Date Modified Username Field Change
2005-01-06 14:31 DonGato New Issue
2005-01-06 14:37 DonGato Note Added: 0000101
2005-01-07 17:31 exp Note Added: 0000103
2005-01-07 17:32 exp Note Added: 0000104
2005-01-07 19:43 DonGato Note Added: 0000105
2005-01-09 09:38 exp Assigned To => exp
2005-01-09 09:38 exp Severity major => minor
2005-01-09 09:38 exp Status new => acknowledged
2005-01-09 09:38 exp Category Bug Report - Interface => Bug Report - Database
2005-01-09 09:38 exp Summary Wrong encoding or wrong data? => DB Entries contain invalid character codes
2005-01-09 09:38 exp Description Updated
2005-01-09 09:38 exp Additional Information Updated
2005-01-09 12:23 DonGato Note Added: 0000118
2005-01-19 07:43 Amour Note Added: 0000147
2006-07-23 18:02 DerIdiot Status acknowledged => resolved
2007-12-06 08:29 epoximator Resolution open => fixed