View Issue Details

IDProjectCategoryView StatusLast Update
0000517HTML & PERLBug Report - Databasepublic2007-06-18 06:24
ReporterIsochroma Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000517: Notify Popup : Behavior Change : Notification Clear only on Browse per Item Listed
DescriptionCurrently, the notify popup (NP henceforth) shows a list of animes with the notify attribute enabled. However, each load of the notify page clears all generated notifys.

There are several issues with this behaviour, namely: first, unintentional window closure (crash, keyboard, etc.) will cause any unchecked notifys to be lost (happens to me on a regular basis).

Second, due to the clear-on-reload behaviour, a periodically-refreshing notify list cannot be pinned to the desktop (ex. Windows XP Active Desktop), or added to custom explorer toolbars (made by third-party applications), etc.

The clear-on-reload behaviour assumes the user has browsed and resolved all notifys, when this may not be the case.

Therefore, it is proposed that each Notify be retained until the user next requests a page from the anime which the notify was generated from. Sub features may include:

1. To prevent backlog overload, a maximum of n notifys can be retained, from the latest to latest+n backwards in history.

2. User control could be provided in the User Preferences section of the site. Items such as retention time, number of notifys, switch to old behaviour (clear on load), etc.

As a final note, special software is being developed:

http://www.anidb.net/forum/viewtopic.php?p=28101#28101

to make this idea functional. However, no functional version has yet been released. The minor change in behaviour suggested herein would allow generic Windows Active Desktop and many other applications to make use of notifys without the complexity and additional overhead of third-party applications.
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2006-09-21 21:50 Isochroma New Issue
2006-09-22 19:34 worf Note Added: 0001048
2007-06-18 06:24 epoximator Status new => closed
2007-06-18 06:24 epoximator Resolution open => won't fix