View Issue Details

IDProjectCategoryView StatusLast Update
0000567HTML & PERLBug Report - Interfacepublic2007-01-13 08:37
Reporterspider0042 Assigned Toepoximator  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000567: My History - Order of Dates Incorrect (Reversed)
Description[ Problem ]
When logged in, and viewing the My History pages located at:
http://anidb.info/perl-bin/animedb.pl?show=myhistory

The table's dates are listed in reverse order (in reference to the Bar 'Graph' and 'Count' columns). It is either the dates, or the other two columns that are reversed.

A list of all pages containing the issue can be found in 'Additional Information'


[ My Guess ]
My guess is that 'Count' and 'Graph' are the columns that end up reversed.
For an example of what I mean by 'reversed' see the 'Additional Information'
(I base the assumption above on the fact that the 'watched' page is correct, though that might be an exception. Whatever the case may be, its probably best that the code is consistent after it is fixed... just my opinion though.)
Additional Information[ List of Pages containing the Issue ]
For the pages listed below as 'REVERSED', both the 'by month' and 'by week' views are effected. (maybe a perl_variable/mysql_order issue and not the code displaying it? or maybe the code that displays reversed was copy-pasted.)

The status of the pages:
- 'added' REVERSED
 - 'watched' CORRECT
 - 'stored' REVERSED
 - 'deleted' UNKNOWN

   (please check 'deleted' - I cannot tell based solely on my personal history)


[ Example ]
Link to my MyHistory page for easy viewing and reference:
http://anidb.info/perl-bin/animedb.pl?show=myhistory&uid=137427&pass=showme
(note: the issue is not specific to guest access. It is a problem on ALL pages displaying MyHistory )

Example of my personal 'added' page:
(this can be better represented/seen at the link above)
---------------------------------------------------------------
Date Count Graph

26.03.2006 898 |||||||||||||||||||
25.04.2006 38 ||
...
02.12.2006 123 |||||
03.01.2007 1744 ||||||||||||||||||||||||||||||||||||
---------------------------------------------------------------

I added all of my data when I first created my account (a lot), hence the largest count number at the bottom.
As it can be seen above, the order of the dates are 'reversed'.
The count of 1744 should be_paired/correspond with the date 26.03.2006 and NOT 03.01.2007
TagsNo tags attached.

Activities

spider0042

2007-01-08 05:49

reporter   ~0001137

Errata:

Typo
The graph given above is my ’stored’ history data, NOT ‘added’.
The link is to ‘added’, but ‘stored’ can be reached through the linked page if desired. Both tables at ‘stored’ (above) and ‘added’ (the link) are an accurate examples of a reversed table.

I apologize for any inconveniences that may cause.

Issue History

Date Modified Username Field Change
2007-01-08 05:31 spider0042 New Issue
2007-01-08 05:49 spider0042 Note Added: 0001137
2007-01-11 16:04 epoximator Status new => assigned
2007-01-11 16:04 epoximator Assigned To => epoximator
2007-01-13 08:37 epoximator Status assigned => resolved
2007-01-13 08:37 epoximator Resolution open => fixed