View Issue Details

IDProjectCategoryView StatusLast Update
0000603HTML & PERLFeature Request - Interfacepublic2008-01-23 10:25
Reporternwa Assigned Tofahrenheit  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000603: remove some fields from non-video type of files
DescriptionAny way to remove the following lines/fields from subtitle entries:
Censored
Source/Quality
Duration
And any way to leave the Quality, Resolution, Source columns under the anime entry list of files empty or just something more usable than 'unknown' or ?.
Tagsfile, subtitle

Relationships

related to 0000649 resolvedfahrenheit simple fileadd/edit page (everyhting minus what avdump can creq) 

Activities

exp

2007-03-17 10:10

administrator   ~0001198

concerning the removal of Censored, Source/Quality and Duration.
isn't it possible that those values can be useful for some files?
i.e. there are some external subs which are marked as source DVD, which is useful information IMHO. not sure if there are any censored subs out there, but even that might be possible. about quality, well, why not set it as translation quality?
duration... i can't really think about a use here. or are there actually subs out there which only apply to part of a video file?

nwa

2007-03-30 09:00

administrator   ~0001213

I seriously don't see how these values can be useful for any subtitle files.
So some subs (ahq comes to mind) are direct rips from DVD-s, marking them as source may indeed make sense, but what about the subs that are NOT ripped from DVD, how do you mark those then?

Censored, meh... I'd say there are different styles of translations, those that use the words 'fuck' 'shit' and so on and then there are those that use 'darn it' 'poop' and so on... besides, you can edit the subs anyway, doesn't matter if they're censored or not.

Quality, how many of us understand japanese to rate the subs separately? :P

Duration, a sub only for part of the video file is simply an incomplete sub that shouldn't be in anidb in the first place. Subs have timestamps, not duration.

fahrenheit

2008-01-20 00:09

reporter   ~0001610

hmm i think the only thing that makes sense going from the file information page for subtitle files is duration as such i've removed that from subtitles files (as of anidb v0.1.47).
the other fields though seldom used do see some use so i've let them stay.

the part of the request related to filetables is obsolete because of the new layout.

nwa

2008-01-23 08:34

administrator   ~0001655

The source field is not useful in any way unless you provide the "fansub" option as well.
Quality field would make sense if there was anyone at all that could actually grade them correctly aka understand Japanese, so it's still useless.

fahrenheit

2008-01-23 10:25

reporter   ~0001656

don't know about the fansub option, we could add it.

as for quality, i think it's not just about translation, you don't need to know japanese to see that some sub is out of sync and there's also styled subs, one sub could be better styled and synced that another.

in my opinion quality is as useful for subs as it is for video files, as in, it's just a reference, if were to ditch quality i would do it globally :P

Issue History

Date Modified Username Field Change
2007-03-13 20:06 nwa New Issue
2007-03-17 10:10 exp Note Added: 0001198
2007-03-30 09:00 nwa Note Added: 0001213
2007-05-10 12:07 DerIdiot Relationship added related to 0000649
2008-01-20 00:07 fahrenheit Status new => assigned
2008-01-20 00:07 fahrenheit Assigned To => fahrenheit
2008-01-20 00:09 fahrenheit Status assigned => resolved
2008-01-20 00:09 fahrenheit Resolution open => fixed
2008-01-20 00:09 fahrenheit Note Added: 0001610
2008-01-23 08:34 nwa Note Added: 0001655
2008-01-23 10:25 fahrenheit Note Added: 0001656
2008-03-12 09:47 nwa Tag Attached: file
2008-03-12 09:47 nwa Tag Attached: subtitle