View Issue Details

IDProjectCategoryView StatusLast Update
0000615HTML & PERLFeature Request - Interfacepublic2016-09-10 03:11
Reporternwa Assigned ToDerIdiot  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2016-10 
Summary0000615: states for certain types of generics
DescriptionWe have states such as 'cd', 'hdd', 'deleted' etc. for refular files and for most types of generics. But what about generics like 'on tv', 'theater'? None of the current states are applicable for them.
The only fixes I can think of are either removing the state icon for those generics completely (thus removing them also from the stats for states), or add a new state called 'never owned' (n/a can't be used since epoxi is planning on using it on god knows what) or something, maybe someone has a better idea...
Tagsgeneric

Relationships

related to 0001356 resolvedDerIdiot streamed type availability for nongeneric files & revision of the state policy for streamed type 
related to 0000131 resolvedDerIdiot Show Type Field for Generic Files 
related to 0002491 resolvedDerIdiot Incorrect file type when adding files manually to MyList 

Activities

exp

2007-04-15 05:56

administrator   ~0001230

I didn't quite get your point.

nwa

2007-04-16 11:13

administrator   ~0001234

Which state would you use for a generic with the 'on tv' or 'theater' type? You got no choice but to leave that as unknown with the big question mark icon, which isn't accurate. That's my point.

epoximator

2007-04-16 12:11

reporter   ~0001235

ehehe, the file state stuff has confused me several times..
i did't use n/a for groupstate because it's not a valid class name. it's a bad reason, i know. an alternative would be 'other'

epoximator

2007-12-06 07:55

reporter   ~0001525

partly done

DerIdiot

2008-05-30 21:57

administrator   ~0002118

what's left to do in here?

nwa

2008-06-09 08:17

administrator   ~0002133

everything?
There are still 4 types of file states - unknown, internal/external storage, deleted, which don't apply to generic states like on tv, theater (and didn't we have a streaming state?)
The best would be if the state icon for those generic states would be hidden, then of course one can't really filter by state.

DerIdiot

2016-09-10 03:08

administrator   ~0003843

Last edited: 2016-09-10 03:11

View 2 revisions

this has been resolved by implementing 0000131, 0002491 and a few other fixes in between.

note though that it requires a stats update as a new database field needs to be filled to properly function. i will probabyly runa full reprocessing for all users, but that will take a while.

Issue History

Date Modified Username Field Change
2007-04-04 09:49 nwa New Issue
2007-04-15 05:56 exp Note Added: 0001230
2007-04-16 11:13 nwa Note Added: 0001234
2007-04-16 12:11 epoximator Note Added: 0001235
2007-11-11 13:25 epoximator Status new => assigned
2007-11-11 13:25 epoximator Assigned To => epoximator
2007-12-06 07:55 epoximator Note Added: 0001525
2007-12-06 07:55 epoximator Assigned To epoximator =>
2007-12-06 07:55 epoximator Status assigned => new
2008-02-13 00:54 ninjamask Tag Attached: generic
2008-05-30 21:57 DerIdiot Note Added: 0002118
2008-05-30 21:57 DerIdiot Status new => feedback
2008-06-09 08:17 nwa Note Added: 0002133
2008-10-06 19:36 worf Status feedback => resolved
2008-10-06 19:36 worf Resolution open => fixed
2009-09-30 17:55 nwa Status resolved => new
2009-09-30 17:57 nwa Resolution fixed => open
2010-07-12 13:00 DerIdiot Relationship added related to 0001356
2010-07-12 13:01 DerIdiot Status new => acknowledged
2016-09-03 12:14 DerIdiot Status acknowledged => new
2016-09-10 03:07 DerIdiot Relationship added related to 0000131
2016-09-10 03:08 DerIdiot Assigned To => DerIdiot
2016-09-10 03:08 DerIdiot Status new => resolved
2016-09-10 03:08 DerIdiot Resolution open => fixed
2016-09-10 03:08 DerIdiot Fixed in Version => 2016-10
2016-09-10 03:08 DerIdiot Note Added: 0003843
2016-09-10 03:08 DerIdiot Relationship added related to 0002491
2016-09-10 03:11 DerIdiot Note Edited: 0003843 View Revisions