View Issue Details

IDProjectCategoryView StatusLast Update
0000753HTML & PERLBug Report - Databasepublic2007-09-13 05:35
ReporterDeimon Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000753: The search reads %20 for spaces
DescriptionWhen searching using Firefox's "Add a keyword for this search" feature every space is recorded as %20 and such, searching for anime with multiple words is not possible.
TagsNo tags attached.

Activities

ninjamask

2007-09-02 21:34

updater   ~0001447

i dont have any problems with that

Nightflame

2007-09-08 19:52

reporter   ~0001450

Got the same problem but for me it takes a step further and encode my spaces as %2520. (As in: " " becomes "%20" and then "%" in "%20" becomes "%25".)

guhungry

2007-09-09 02:30

reporter   ~0001451

Last edited: 2007-09-09 02:31

It seems like a browser's problem.

Deimon

2007-09-11 12:46

reporter   ~0001459

It is not a browser problem. All other sites work perfectly.
Just add a minor str_replace code that replaces "%20" to " " and it is fixed.

exp

2007-09-12 05:57

administrator   ~0001461

Actually, this is probably a browser problem. Manually adding %20 to a search query URL works as expected. The server _does_ convert %20 to space (it does a normal query decoding run).

Nightflame

2007-09-12 07:02

reporter   ~0001462

I think I've found the problem!
Works perfectly for me since I updated the url to use "anidb.net/.." instead of "anidb.info/.." ^^

Issue History

Date Modified Username Field Change
2007-09-02 07:01 Deimon New Issue
2007-09-02 21:34 ninjamask Note Added: 0001447
2007-09-08 19:52 Nightflame Note Added: 0001450
2007-09-09 02:30 guhungry Note Added: 0001451
2007-09-09 02:31 guhungry Note Edited: 0001451
2007-09-11 08:30 epoximator Status new => closed
2007-09-11 08:30 epoximator Resolution open => no change required
2007-09-11 12:46 Deimon Status closed => feedback
2007-09-11 12:46 Deimon Resolution no change required => reopened
2007-09-11 12:46 Deimon Note Added: 0001459
2007-09-12 05:57 exp Note Added: 0001461
2007-09-12 07:02 Nightflame Note Added: 0001462
2007-09-13 05:35 exp Status feedback => closed
2007-09-13 05:35 exp Resolution reopened => no change required