View Issue Details

IDProjectCategoryView StatusLast Update
0000766HTML & PERLBug Report - Interfacepublic2008-02-25 08:12
Reportertwpol Assigned Toepoximator  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000766: Main/front page sidebar lists (Latest Additions, Anime Calendar, etc.) layout badly in IE
DescriptionThe lists of latest additions, anime calendar, etc. found on the right-side of the front page don't lay out well in IE - the link for each item is 1 line down from the date/number, making each row twice as high as it should be.

The problem is caused by the following rule in anidbstyle.css (2978-2981):

#layout-content DIV.main_all DIV.rightbar LI A {
    DISPLAY: block;
    MARGIN-LEFT: 4em
}

Removing both CSS properties makes the list items layout correctly in IE 7. I can't be sure removing both properties will not break the layout in other browsers but, from my understanding of CSS, it shouldn't.
Additional InformationMozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; Media Center PC 5.0)
Tagslayout

Activities

twpol

2007-09-22 23:10

reporter   ~0001467

Last edited: 2007-09-22 23:11

OK, so on further inspection, this change does mess up the layout for items which have long, wrapped titles. Doh. :(

Instead of removing any styles, adding
  margin-top: -1.2em;
to the A for Internet Explorer only would be a possible solution.

Alternatively, changing the two existing properties to:
  display: inline-block;
also works (margin no longer being set), but that definately wont work in other browsers either.

A completely different solution, which I believe will work in all (reasonable) browsers would be to style the LIs with:
  padding-left: 4em;
And the SPANs with:
  margin-left: -4em;
And remove the two properties on the As.

fahrenheit

2008-01-20 01:15

reporter   ~0001618

you need to state what is your css stylesheet (check your profile)

twpol

2008-01-20 09:26

reporter   ~0001626

Actually, I don't, because it happens on all styles because the CSS is in the core file. The problem occurs with no style set and with the style "http://static.anidb.net/css/harustyle/harustyle.css", at least.

DerIdiot

2008-01-21 16:45

administrator   ~0001639

most css styles are incompatible with IE as M$ blatantly ignores any sort of standards. long ago we decided to mainly ignore IE as well.

solution for your problem: use the anidb-hack style that should be okish for IE. for any other style i recommend you use a decent browser like firefox or opera.

Issue History

Date Modified Username Field Change
2007-09-22 22:54 twpol New Issue
2007-09-22 23:10 twpol Note Added: 0001467
2007-09-22 23:11 twpol Note Edited: 0001467
2008-01-20 01:15 fahrenheit Note Added: 0001618
2008-01-20 01:15 fahrenheit Status new => feedback
2008-01-20 09:26 twpol Note Added: 0001626
2008-01-21 16:45 DerIdiot Note Added: 0001639
2008-02-10 22:48 ninjamask Tag Attached: layout
2008-02-25 08:12 epoximator Status feedback => resolved
2008-02-25 08:12 epoximator Resolution open => fixed
2008-02-25 08:12 epoximator Assigned To => epoximator