View Issue Details

IDProjectCategoryView StatusLast Update
0000839HTML & PERLFeature Request - Interfacepublic2008-12-08 16:25
ReporterAmour Assigned Tofahrenheit  
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000839: File order is not by size anymore since AniDB Update - 0.1.46
DescriptionOn anime page, there is a known bug for the file order. It should be by filesize, but now it is by groupname.

There need to be an option to allow order by filesize like before. Thanks.

Order by groupname is really a mess: should I change to ^Amour^ to be on top?

If you dislike order by filesize, then make it an order by subtitle language: at least all languages won't be mixed-up like that.
Tagssorting

Activities

epoximator

2007-12-10 08:58

reporter   ~0001550

it was a intentional change done after several mods had discussed it. i don't think it'll be reverted. the file list is sortable in anime3.

i don't see how sorting by size is not "a mess". it's a pretty arbitrary attribute. should you encode bigger files to be on top? the only reason you'd want it by size is because of the idea that "bigger is better", which is naive thinking at best.

and i doubt languages are more mixed after this change. like filesize had anything to do with language...

exp

2007-12-10 09:28

administrator   ~0001551

It could of course be considered whether to add a special profile option to get the old sorting by size behaviour back if wanted.

The question there is whether there would be enough demand for such an option.

In the long (very long?) run we'll be moving on to anime3 and could then in theory support arbitrary sorting criteria. But even that would need a profile option, wouldn't it?

So this might not be an on/off sort by size kind of option but rather a dropdown which would currently only have two entries "by group name, version, ..." and "by size" and which could be extended for anime3.

BYe!
EXP

fahrenheit

2007-12-15 04:21

reporter   ~0001566

although anime3 currently uses the same sorting by default as anime, a user can sort each file table by whatever selectable column he deems fit, including fid, size, resolution, source (forgot but I'll add it again), quality and user count.

and as a side note, the sort isn't only by groupname, although i think for 90% (?) of the cases there will be no difference between the sorting by groupname and the current sort.

I personally like the new sorting, and like exp and epox said, you can sort by size on anime3, if you wish I can make it the sorting by size by default as a preference on anime3 but you won't like that because the default sort is going to stay the same. You just get to wait for the table to sort on top of the time it takes to render the table.

This also applies to any sorting you wish, even if exp creates a profile option there will always be a default db sort+js render that will always be faster than a js sort+js render.

exp

2007-12-15 08:39

administrator   ~0001567

will the delay be that noticable?
I mean in most cases we're talking about sorting a list with only 5-20 entries.

BYe!
EXP

fahrenheit

2008-01-13 00:51

reporter   ~0001583

not really in some cases yes, but normally no (<1s)

Amour

2008-02-20 08:09

reporter   ~0001711

I do not know if I have to open a new tracker entry for that, but I just noticed that when you double-click on the "Size" column, it will try (often fails) to sort alphabetically!

This is an issue because it will sort like:
*123.456.789 (normal video range)
*2.345.678.901 (pack > 1 Gb)
*345.678.901
*456.789 (subtitles < 1 Mb)
*567.890.123

fahrenheit

2008-02-20 21:57

reporter   ~0001712

amour, as usual you have to give an example url for me to check.

Amour

2008-02-21 21:30

reporter   ~0001715

Ok, maybe the problem is different. When you click on the "Size" column, it won't sort as expected. It will sort:
1) By group/no_group category
2) By group name
3) By CRC checked
4) By size

When you only want it to do:
1) By size

Example:
http://anidb.net/perl-bin/animedb.pl?show=ep&eid=17629&lang=

fahrenheit

2008-02-22 01:04

reporter   ~0001716

Last edited: 2008-02-22 02:36

fixed the size issue, it was me not taking into account several of the new changes.

ninjamask

2008-02-22 09:15

updater   ~0001724

on amours example page:
also not working is the sorting by group

and i dont get the logic behind "sorting by CF" and "sorting by resolution"

fahrenheit

2008-02-22 17:43

reporter   ~0001726

fixed it again, i broke it later in the night.

Sorting by CF sorts by video codec sorting by resolution doesn't work very well because it's a simple text compare, i don't have an good way to sort by resolution taking into account both the width and height if you have one feel free to tell.

ninjamask

2008-02-22 23:26

updater   ~0001729

parsing the values and sorting it by the total value of the multiplication maybe?

exp

2008-02-23 00:32

administrator   ~0001733

or just sort by only one of them, i.e. width

fahrenheit

2008-12-08 16:25

reporter   ~0002442

okay, added the feature, this will only be available for the ajax animepage.

You can choose one column to make the default sorted col, from the available columns, and also choose the default sorting order, from ascending or descending.

Also as a bonus i've implemented a way to set what file table columns you wish to display and by what order they should be displayed, please note that i don't care what you set the columns to be, if you wish you can remove all columns for all i care.

Both sets preferences can be set either via the profile>Javascript tab or by the Page Preferences interface in the animePage.

Issue History

Date Modified Username Field Change
2007-12-09 22:03 Amour New Issue
2007-12-10 08:58 epoximator Note Added: 0001550
2007-12-10 08:58 epoximator Category Bug Report - Interface => Feature Request - Interface
2007-12-10 09:28 exp Note Added: 0001551
2007-12-12 09:59 epoximator Severity major => feature
2007-12-15 04:21 fahrenheit Note Added: 0001566
2007-12-15 04:22 fahrenheit Priority normal => low
2007-12-15 04:22 fahrenheit Status new => confirmed
2007-12-15 04:22 fahrenheit Resolution open => suspended
2007-12-15 04:22 fahrenheit ETA none => > 1 month
2007-12-15 04:22 fahrenheit Build => 0.1.46
2007-12-15 08:39 exp Note Added: 0001567
2008-01-13 00:51 fahrenheit Note Added: 0001583
2008-01-21 16:16 DerIdiot Status confirmed => assigned
2008-01-21 16:16 DerIdiot Assigned To => fahrenheit
2008-02-10 22:48 ninjamask Tag Attached: sorting
2008-02-20 08:09 Amour Note Added: 0001711
2008-02-20 21:57 fahrenheit Note Added: 0001712
2008-02-21 21:30 Amour Note Added: 0001715
2008-02-22 01:04 fahrenheit Note Added: 0001716
2008-02-22 02:36 fahrenheit Note Edited: 0001716
2008-02-22 09:15 ninjamask Note Added: 0001724
2008-02-22 17:43 fahrenheit Note Added: 0001726
2008-02-22 23:26 ninjamask Note Added: 0001729
2008-02-23 00:32 exp Note Added: 0001733
2008-12-08 16:25 fahrenheit Status assigned => resolved
2008-12-08 16:25 fahrenheit Resolution suspended => fixed
2008-12-08 16:25 fahrenheit Note Added: 0002442